Permalinks showing index.php prefix

I have three sites in Local, everything fine. On the third one though, permalinks show the “index.php” part. I can choose %postname% in the permalink settings, but the other options still show index.php anyway. On Apache this happens when .htaccess is not properly configured, but I’m using the preferred settings, so nginx it is.

The three sites are almost identical in setup. Only difference is, for the first and second sites, I imported them from other Wordpress installs (files and database, not from Local).

Not a huge problem, but would like to know how could I control this?


A post was merged into an existing topic: Weird URLs Question