Permission Problems?

Hi I am completely new to localWP - I was using xampp before in the past years.

So first time after setting up my first site I tried to delete the themes that came with the latest WP version. There was an error saying that WP was unable to completely delete the selected theme “twenty-whatever”. So I had a look on my local folder and I saw that the files are gone but the folders are still there (and deleted them manually in Windows Explorer)

Then I installed a new Theme, then Elementor and even uploaded my Elementor Pro plugin and activated. But then again I ran into problems. The Elementor Site Editor won’t start. The Plugin reports that there are “permission issues with folders like Wordpress root, Wordpress Uploads, Elementor Uploads”.

How can I find out what permissions are needed and how do I fix this? I am not super experienced, so please bear with me if I don’t fully understand every detail. It was my first time, trying to use localWP.

What issue or error are you experiencing?

  • Local Version:
    Version 7.2.1+6433

  • Operating System (OS) and OS version:
    Windows 10

Local Logs (12.6 KB)

Hi @SeriousToni

You likely have some security applications that are locking down folders or blocking Local from making changes.

You start by checking here:

Thanks, but I already read through that one. Hosts file was already writable. Securitry Apps are Windows Defender only on which I set the permissions during the installation.

I tried to swap between Apache and Nginx and now I even get the EPERM error message you mentioned. Where the hell is this coming from? :frowning:

EDIT: I even deactivated Windows Defender - but it didn’t change anything.

You mentioned using XAMPP before. Are you still running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

Out of curiosity, did you start running into issues after updating Local? If that’s the case, you might try exporting and reimporting the site. Sometimes this will help resolve similar problems.

Keep us posted and we’d be happy to help further!

No other tools like xampp installed, no.
I just downloaded local wp and started. No update.

Hi @SeriousToni

You may need to do some manual permissions checks and fixes like I mentioned in a similar thread here:

Hm every user / admin has full read/write permissions. I think I’ll give up on this and go back to xampp

Hi @SeriousToni - Thanks for giving Local a spin! We definitely get using what is best for your needs. If you ever circle back to Local you know where to find us if we can help any further.