Permissions error creating 2nd local site

What issue or error are you experiencing?

Error Command Failed


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Everytime I try and create another site this happens


System Details

  • Local Version: Version 8.2.1+6583

  • Operating System (OS) and OS version:
    Windows 10


Local Logs

Attach your Local Logs here ([Help Doc - Retrieving Local’s Log](
local-logs1.zip (27.7 KB)
error creating site
))


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I have one site up and running fine, it’s configuration is exactly the same as I’m trying to create here.

After getting the error message, if I try and open the site, it goes to the WordPress setup menu, i.e. select site language etc, but after selecting English UK, it says there has been a critical error,

Hello @pzh20 - thank you for your question :wave:

Are you using any special characters in the admin username or password of the site?

Can you please detail your site settings?

  • Web server
  • PHP version
  • Database
  • WordPress version

Thank you!

Sam :green_heart:

Sorry Sam, I assumed that information would have been in the logs,

Webserver: NGINX
PHP Version: 8.1.23
Database: MySQL 8.0.16
WordPress version: Latest - LocalWP seems to have trouble displaying it

I’m not using any special characters in the username or password.

I have another site with exactly the same configuration running without any problems. It’s site folder is on the same disk as the one I’m trying to set up. It’s exactly the same.

I’ve removed it and deleted the folders, tried it with different names, nothing works. I’ve just this minute tried to set up another site and it fails with the same problem.

Ver strange as I’ve had multiple sites running in LocalWP before without a problem and LocalWP is at the same version I created the one that’s working. The disk volume is the same where I store My Documents and there’s been no problems with permissions on any other file.

Regards
Pete

Sam,

Yesterday, no matter what I did, I ran into the above error. Today I thought I’d try again, this time creating a site on my local hard drive, and it worked. So I changed the preferences again, bat to me external hard drive, and created another site. This worked too.

Nothing has changed overnight, and I have no idea why it’s working now and not before.

I’ll keep this thread open for now as it might happen again, but for now, I’m up and running again.

1 Like

Hi @pzh20 -

Huh! That’s strange - but thank you for letting us know it’s working. Yes, let’s keep the thread open and let us know if you run into any more trouble.

Happy Building :green_heart:

Sam