PHP Startup: Unable to load dynamic library 'php_imagick.dll'

Hi, I keep getting notifications that my site is using HTTP but the Local SSL cert isn’t trusted. I can click the trusted link, confirm through the Win Administrator popup but it forgets this and I have to do it again when I load the site.
Under the OpenSSL Version there is an error PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: C:/Users/info/AppData/Roaming/Local/lightning-services/php-7.4.1+5/bin/win32/ext\php_imagick.dll (The specified module could not be found.), C:/Users/info/AppData/Roaming/Local/lightning-services/php-7.4.1+5/bin/win32/ext\php_php_imagick.dll.dll (The specified module could not be found.)) in Unknown on line 0

Hi, I’m also having exactly the same issue after updating to the latest local by flywheel version 5.2.5.

Any insights on fixing this would be greatly appreciated.

I’m not even able to open Local after updating it to the last version…

I am also having this problem (sans the Certificate trust issue) on the most recent version of local 5.3.1+3095. The specified dll is there so it’s not an issue of it not being there.

I had the same issue running Local 5 on Windows. Having tried several versions of the imagick library, I gave up.

I was trying to use the built in WP image editor and, having added the following code, things worked without the imagick library (the error is still showing in Local):

public function use_gd_image_editor( $editors ) {
    $gd_editor = 'WP_Image_Editor_GD';
    $editors   = array_diff( $editors, array( $gd_editor ) );
    array_unshift( $editors, $gd_editor );

    return $editors;
add_filter( 'wp_image_editors', 'use_gd_image_editor' );

Hi @DynamicArray
Can you help me for where i can put this code for resolve the problem?

Leonardo Grabow
Buenos Aires - Argentina

In your theme’s functions.php or in your plugin file somewhere if you’re working with a plugin.

Thanks @DynamicArray

The Local Wp continue with not reconogized this .dll of php_imagick.

I will continue any solutions.

Leonardo Grabow
Buenos Aires - Argentina

Same error here:

Warning: PHP Startup: Unable to load dynamic library 'php_imagick.dll' (tried: C:/Users/user/AppData/Roaming/Local/lightning-services/php-7.4.1+10/bin/win64/ext\php_imagick.dll (Can't find the module.), C:/Users/user/AppData/Roaming/Local/lightning-services/php-7.4.1+10/bin/win64/ext\php_php_imagick.dll.dll (Can't find the module.)) in Unknown on line 01.1.1d 10 Sep 2019

The module is there. But if you see the syntax in the last folder it uses the “” instead of the “/” for the php_imagick.dll library.

Something must be coded wrong somwhere in Local

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.