PHP7.4 fails to find imagick module

Issue Summary

PHP7.4 fails to find php_imagick.dll
File name may be incorrect - it seems to request “php_php_imagick.dll.dll” - however if I create a duplicate file with this naming convention it still fails to find the module.
Possibly a dependencies problem.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

Yes all

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes, however, the module will be missing.


Install Local WP and spin up a new instance of WP on Apache with PHP 7.4.3 and MySQL 8.0.16

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional

Win 11 Pro

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

(upload:// (16.2 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I found this, which suggests that ImageMagick can be fickle:

It also clarified the difference between TS and NTS versions mentioned in the thread below.

This thread also suggests that finding the correct version of ImageMagick seems to be a solution:

Also paths and dependencies especially come up regularly as a cause, which seems more likely.

Any way to get this reliably resolved as there are a number of threads that have a similar problem?

Hi @nisiwi

Can you drop a copy of your Local Log in here? We’d be happy to take a deeper look.

Retrieving Local’s Log File

Thanks @Nick-B
Apologies for delay. I’ve been setting up WAMP, just sorting SSL.
Log file attached. (24.7 KB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.