PID4 (system32/ntoskrnl.exe) blocking the port 80

when I run my site i get a message: Heads-up! Local’s router is having trouble starting. Learn more
When I google the Internet: I realize the System uses Pid 4 (for port 80) in task manager, and of course, since it is a system file there is no way to end it. I read so many posts on the internet about this, none could help. I even do not have
Microsoft Windows [Version 10.0.19043.1288]
(c) Microsoft Corporation. All rights reserved.

C:\Users\Reza>netstat -nao | find “:80”
TCP [::]:80 [::]:0 LISTENING 4


Pid4 is a system file.

Ray’s Travel

Last started today

I have the same issue. is there an answer to this?

Sounds like an issue I was having a while back with the BranchCache service hogging port 80, try disabling that maybe?

"In most cases, Local can’t start the router because there is something already occupying port 80. There are only two options to get things working:

  1. Set Local to use localhost Router Mode.
  2. Stop whatever is already listening on port 80 and restart Local."
    I would do the first one: Set Local to use localhost Router Mode (preferences, advanced, router mode: localhost)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.