Potential cURL or SSL error


I am trying to set up the popular WP Offload S3 Pro plugin, however, I’m hitting issues which I believe are related to Local by Flywheel rather than the plugin itself.

I am getting this error:

Error fetching buckets — Error executing “ListBuckets” on “https://s3.amazonaws.com/”; AWS HTTP error: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see libcurl - Error Codes)


It looks to be something related to either cURL or perhaps SSL.

Note that I already have my SSL certificate installed and set to Trusted, but the issue persists. I have tried restarting the site, Local and my machine but to no success.

I am running Local 2.2.4 and macOS High Sierra 10.12.35.

Thank you

Update, I just SSH’d into the local site and ran the following command:
apt install ca-certificates

This definitely made an impact as the error has changed:

Error fetching buckets — Error executing “ListBuckets” on “https://s3.amazonaws.com/”; AWS HTTP error: Client error: GET https://s3.amazonaws.com/ resulted in a 403 Forbidden response: AccessDeniedAccess DeniedCDDFFD (truncated…) AccessDenied (client): Access Denied - AccessDeniedAccess DeniedCDDFFD71389E8A6FxBtyCFinY0WxvJ9nbNtWTAkfW9Lumai4SOuIdy55Gws0mKa+0qDeHKyxb2zdnkcTGAo1uTV5+1Y=

However, it still doesn’t work.

Any help is appreciated, thanks.

Glad you got it with apt install ca-certificates! Just a heads up, this is resolved in Preferred 1.2 and Custom 1.3.

Considering the error is a 403 Forbidden, be sure to check your AWS credentials and permissions.