cURL error 60: SSL certificate problem: self signed certificate

Hi there
I am using wpml local flywheel as normal
when i try to change it to a directory based system for languages i get:

When WPML accesses https://xxxxxxxxxx/en?____icl_validate_directory=1 it gets:
cURL error 60: SSL certificate problem: self signed certificate

I know u have this:

but i cant do this all the time
can you offer solutions to this or i cant use local at all for local development


Hey @bomakalu – Thanks for your patience with all of this, it’s definitely a hard issue to track down and replicate.

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:
  • Does this happen for all sites in Local, or just one?
  • Do you have a screenshot of the error you are seeing in the browser?


I realise this is an old thread but I am experiencing the same issue so thought I would share what I have.

My environment
Local Version: 5.10.4+5377
OS: MacOS 11.3.1 (Big Sur)
Local Log: Attached
local-lightning.log (369.5 KB)

Does this happen for all sites in Local, or just one?
Currently I am experiencing the issue with a specific area of Oxygen on all Local sites. A cURL call is attempted, and the Self Signed Certificate causes the following error to be thrown:

Items not loaded. cURL error 60: SSL certificate problem: self signed certificate
Screenshot: Attached

I have seen recommended solutions elsewhere to download cacert.pem from curl - Extract CA Certs from Mozilla and then add the following to each Local site’s /conf/php/php.ini.hbs file:
curl.cainfo = “/path/to/cacert.pem”

Unfortunately this has not made any difference. I do see the updated entry in phpinfo():
Screenshot: Attached

How to replicate
Unfortunately I can only provide steps to replicate with a site running Oxygen:

  1. Edit a page using Oxygen
  2. Click to +Add a component
  3. Open the Library tab and select Design Sets
  4. Click on your current site’s design set

This initiates a cURL call, which generates the error.

Based on the few posts I have seen on this issue on other forums, I do not believe the issue is specific to Oxygen. Rather it seems to be an issue with any cURL call with Local and Self-signed certs - for example, accessing WP REST API via cURL.

Any help would be appreciated.


I am having the same error when i try to import demo data in my local site.

Does anyone how to solve this? I asked in Getflywheel and they said to me that they don’t support this kind of questions.

Thank you


Hi @sergiodiazmartinez

We would be happy to assist with Local troubleshooting! Could you provide some more details to help us troubleshoot further?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

Hi @Nick-B ,

Thank you for answering so fast

This is the info:
OS: macOs Ventura 13.2.1
Local version: 6.6.1+6281

Hi @sergiodiazmartinez

Thank you! Can you also share a copy of your Local Log? Retrieving Local’s Log File

Is this issue happening on just one site or all sites?

Here you have my Local logs. (38.0 KB)

Hi @sergiodiazmartinez

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Have you gotten any prompts while doing work to enter authentication? Are you running any other developer applications simultaneously?

I am getting an error with the CiviCRM plugin, GuzzleHttp\Client returned cURL error 60: SSL certificate problem: self signed certificate, where it is trying to make local calls to the system but it is running into the self-signed curl issue as well. I read on other articles about this and the only way I can get this to work is to copy the self-signed certificate for my local site and save it into the ca-bundle.crt in the wp-includes/certificates folder. I did this just for testing to see if I could get the issue to resolve itself. This is the default path for the ca certificate file from LocalWP.

Once I was able to get things working by doing this, I then changed the php.ini.hbs to use a ca pem file I have on my computer for openssl in which I also appended the self-signed cert to it. Doing it this way also worked for me and prevents issues when WP upgrades and the ca-bundle.crt gets updated as well.

I am running the following:
macOS Monterey 12.6
LocalWP 7.1.0+6396

Thank you for sharing your findings @rbaugh!