Push from Local to Staging on Flywheel doesn't bring over WordPress DB changes

Issue Summary

Push from Local to Staging on Flywheel doesn’t bring over WordPress DB changes. Plugin deactivations, themes, etc. See screenshots comparing Local to Staging on Flywheel.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? Yes, I’ve replicated this on multiple websites.


Pull Live from Flywheel into Local. Make plugin and theme changes. Push files and database changes to staging on Flywheel. Login to Wp Admin on staging on Flywheel and WordPress settings are not imported as expected.

System Details

  • Which version of Local is being used? 5.9.8+5191

  • What Operating System (OS) and OS version is being used?

    • MacOS Catalina: 10.15.7

local-lightning.log (291.9 KB)

The most likely reason that the database changes weren’t deployed would be that the “Include Database” option wasn’t checked.

Can you try pushing again and verify that this option is checked?

Yup. I always push that. :confused: I’ll try again. But it hasn’t seemed to matter.

  • Israel

Screen Shot 2021-02-15 at 11.36.20 AM.png

It seemed to work after I tried pushing a couple of times. But it never has worked the first time I push it. :frowning:

Thanks for the heads up, and I’m glad that the most recent push has deployed the database!

Yup. Did it and it worked this time. I’ve had this happen multiple times this week. So my guess is that it doesn’t work the first push for me when pushing a site for the first time to a staging site. It worked after I did it a second time.

  • Israel
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.