Receiving Error when trying to create new site - Just installed Local

Issue Summary

Just installed Local. Unable to create a new site without receiving an error. After clicking OK on error and starting site it looks like the database has not been created.

When going to the local wordpress instance the error starts with this " Fatal error : Uncaught mysqli_sql_exception: Table ‘local.wp_options’ doesn’t exist in C:\Users"

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All Sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Click start new site and use default parameters.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 10 Professional

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-lightning.log (22.9 KB)

Hi @willh

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

If you’re still having trouble feel free to share your Local Log so we can look further! Retrieving Local’s Log File

Hi Nick, thanks for the advice. I have shared my local log file (see my original post) and tried the troubleshooting recommended at the Router Mode link with no luck.

Hi @willh - There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering. Keep us posted and we’d be happy to help further!

Hi Nick, see attached logs and the error popup image that happens when creating a new instance. (6.0 KB)

i am also facing this issue ,how to solved this problem
here is my local-logs
local-lightning.log (97.1 KB)

Hi @willh and @mohammadmehdi

Both of your logs include errors like this:

Error: The site is experiencing technical difficulties

I believe that is WordPress’s text when it encounters a PHP fatal error. You might be able to get a better idea of what exactly is erroring by changing WP_DEBUG to true in the wp-config.php file.

In my case the reason that the error is happening is because the database was not completely installed, so when it runs a query it does not find the table. MySQL exists and there is a database but there are no tables in that database.

I’ve been unable to identify why that database install is not completed.

Clicking on Open Adminer:

Trying to open the site:


In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.