Redirect issue with ipv6 loopback enabled and browsersync

Hi there, I’m using grunt browsersync. When I enable the ipv6 loopback (which I have to otherwise it’s very slow), the site redirects constantly back to the homepage (localhost:3000) when clicking on a link (ie localhost:3000/events wouldn’t work). I proxy a .local url. I tried to resave the permalinks but that didn’t make a difference. Anyone any idea what the problem could be?


You might need to set the WordPress Site URL/Home URL in WordPress Admin » Settings » General to localhost:3000.

You shouldn’t need to change your WP site settings but rather might have an error in your browsersync settings. Are you displaying errors to the terminal when you run grunt? I am using Gulp instead of Grunt, so I cannot comment specifically.