Seeing error: Warning! This site's WordPress URL settings do not match the host set in Local

Issue Summary

  1. I am seeing a banner that says “Warning! This site’s WordPress URL settings do not match the host set in Local”. If I click the FIX IT button, the banner disappears for a moment then reappears.

  2. I also see a Heads-up! Your site is using HTTPS but the Local SSL certificate isn’t trusted message. If I click TRUST, I get a UAC prompt and the certificate gets “trusted”, but the banner keeps returning.

Troubleshooting Questions

  • This happens on all sites

  • This has only been happening since I updated to the latest version (5.10.3+5332).

  • The banner is incorrect - the WordPress URL settings do match those found in Local. See screenshots at the end.

  • Re. the certificate: inspecting the certificate in the browser shows the cert is there (“Super Fake Company, Fake.”). I’ve located the certificate in C:\Users\Charles\AppData\Roaming\Local\run\router\nginx\certs and installed it manually, but I still see the heads-up banner.

System Details

  • Which version of Local is being used?

    • 5.10.3+5332
  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional 20H2 19042.868
  • Attach the Local Log.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.