Since updating to LocalWP 8.x, all development websites won't load

What issue or error are you experiencing?

Since updating to LocalWP 8.x, all development websites won’t load, now when I attempt to load a website all I see is a blank web page with ‘It works!’ displayed.
I have dozens of websites now inaccessible since the update.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I tried a downgrade, still the same.
I tried cloning a website, the same.
I have tried making a new blank website, the same.

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    Mac 13.6.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (611.2 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hello @DarrenStevens,

Thank you very much for your question. We’ve been trying to reproduce the behavior you’re seeing but unfortunately, we cannot.

Can you please share more about your process - a video walking through what you’re seeing could be helpful too.

Also, the following information would help us debug this issue:

  • Your WordPress version
  • Have you made any modifications to Local’s config files?
  • Are any of these sites using Apache?
  • Have you restarted your computer?
  • Do you see any errors or banners in Local?

Thank you so much!


1 Like

The “It Works!” Page seems like it’s coming from some other source, not Local. Is there some other web server active?


Agree with @afragen, something else appears to be running on your machine and bound to port 80 – and the on-screen message says that it’s an nginx server. Your log file is full of “address already in use” messages when the nginx server in Local tries to start.

Do you have some other local development tool installed and running? If so, shut it down before starting Local. Also, it might be worth restarting your machine before doing anything further.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.