Sites fail to boot or create on Fedora 39

What issue or error are you experiencing?

  • mysql service is spewing out errors, and can not start


  • The error does not exist when using MySql 5.7.
  • I have reinstalled Local
  • I have tried it on existing sites that worked fine in Fedora 38
  • I have tried adding a fresh site, it still does not work
  • I have run a fresh, clean install of Fedora 39 in a VM, and it fails there as well. It’s a bit different though, but still related to the MySQL service
  • I have tested it with a VM and Fedora 38, and there Local works fine.

If anyone knows a solution or quick fix, it would be greatly appreciated.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

  • Install Fedora 39 on your machine, or in a VM
  • Install the latest Local release
  • Just add a new site in Local and start it, or start an existing site, and the error will pop-up.

System Details

  • Local Version:
  • 8.1.0
  • Operating System (OS) and OS version:
  • Fedora 39
  • I am using docker for other development need, but during testing no containers were running

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning-verbose.log (55.5 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Cross sharing this thread with one of our Local Devs that might provide some helpful information as well. If you have related questions or concerns you can also share over there as well:

Thanks Nick for sharing some information. I will look into that.

(Interesting addition that came accross: the default Docker image of WordPress does not work well on Fedora 39 either in most docker-compose setups I have seen, the container is running, but it will result in err_connection_reset. From Locals perspective, this will return a 502 as nginx can not connect to the container)

1 Like

Screenshot from 2023-12-10 19-05-50
in Fedora 39 it doesnt create site

Hi @mizaistom

Did you catch this thread above and test using those steps?

yes i did do all the steps but keeps on giving me the same error , can you try in fedora 39 because thats fedora 36

Sorry that you encountered this, @mizaistom and @leichim.

As a workaround for now, please could you try installing Local via yum or Fedora’s Software Installer as above, then also installing the missing dependency like this?

sudo yum install libxcrypt-compat

Restart Local, and you should find that MySQL runs when you create and start a new site. I tested this under Fedora 39 and all is then well for me:

(The underlying issue is that the vendor-supplied version of MySQL that Local defaults to (8.0.16) is linked against a dynamic library (libcrypt.so.1) that was removed in newer versions of Linux/Fedora. We’ll look at upgrading to a newer version of MySQL (8.2.x) that links to later libcrypt versions, but I don’t yet have a timeline for this work. I hope the workaround helps you for the time being.)

3 Likes

thank you it worked

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.