SQL database not importing correctly

Hi everyone, I hope you can help with this. I have been trying for 2 days to import my wordpress website to local. I have spoken several times with my hosting providers who have suggested several different ways to import but all have failed. I have been able to create a new website in local so that works it’s just a problem importing my existing site. I downloaded my public_html file and unzipped it, I then merged with that my .sql file and re zipped the two together. I have tried adding the new file by dragging it in and also using import from the menu, but either way it gets stuck with the same issue re the database as per the screenshot below. When I check the site afterward it’s missing quite a lot of stuff.
Not sure if this could be an issue, I wouldn’t think so but I use the WPS Hide Login plugin and thought it might be worth mentioning. Is anyone able to help me with this, please :slight_smile:

P.S I’m using the latest version of Local

Try just zipping the .sql file and your wp-content folder. Drop onto Local for importing.

Hi Afragen, thanks for your reply. OK so I just tried that and got the exact same error :frowning: The reason we were trying using public_html is because I have some subdomains and I didn’t want them coming over and getting imported. My hosting company said public_html should be just my main domain :woman_shrugging: Do you have any other ideas?

Do you have a single .sql file that is an export of your database?

I believe so. This is it here, it was separate but I tried merging it as well but didn’t work either way. Is it possible to add the public_html and then add the .sql seperately?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.