SSL Will Not Stay Trusted

Issue Summary

No matter what I do, the SSL certificates will not stay trusted in Windows 10. I can restart my browser, run as administrator, etc and the SSL doesn’t stick. This is causing an issue when trying to pull from APIS (like YouTube) that require a secure connection.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    This happens in all my sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes I can create sites no problem


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    Version 6.3.0+5756

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional

Windows 10

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

No one? Still no fix for this. I have an API call to YouTube that will not work locally because of this.

I’m having the same issue with Win 10 Pro. But once I open the site in the browser I’m seeing https and there’s no warning about unsecure. So maybe it seems Win 10 recognizes the TRUST to TRUSTED but for some reason Local loses track.

More or less, for me atm it’s a non-issue as long as the brower uses https

The same issue happening on Mac also since the last update…they must have messed up the update…

Im having the same issue after the last update. On OSX the cert is “always trusted” in the keychain, but in local wp is not marked trusted.

Hi @tcarson and @drikfan - thanks for highlighting this for us. We’re digging into this now - see my post in this thread for more information!

Thanks will watch for an update.

Updated…but SSL problem still there? Bummer…maybe next one.

June 2, 2022. Local v6.4.0+5927
SSL issue still not fixed. Site shows non-secure.

Im still having this same issue with the new version of Local - going to have to install an old version again. Sigh…

To clarify, the issue is still happening in the new 6.4 release. Reverting to 6.3.0 fixes the issue and the SSL stays “trusted”

drikfan, not me. (Mac, Catalina) I reverted to 6.3.0, have certs that say “always trusted” in my keychain, and even when I allow an exception in Firefox, it still is not a secure connection. Same behavior in Chrome. Frustrating.

I did notice I’m actually on Local 6.3.0+5756
Also - on an m1 max, Monterey 12.1

Anything past 6.3 causes the issue for me.

@yomartin and @drikfan - the Mac issues will be resolved in Local v6.4.1 which will be available on our releases page shortly. We had several users confirm the fix was working for them in the Beta build we published last week.

As for Windows (original post here), there does seem to be a UI bug specific to Windows like mfs_au explains here - SSL Will Not Stay Trusted - #3 by mfs_au. The certificate is trusted, but the UI reverts back. The developers started taking a look at this this morning.


Thats great - thanks austin!

1 Like

I’ve been dealing with this issue consistently on Windows 10 for years, since probably the 5.x.x days. I’m not sure I remember a time when it stayed “trusted” in the UI.

currently Local: 6.4.2.+6012
Win 10 Pro

Still an issue. I’m not sure whether it is only a visual bug. I had to force another certificate via config in order to make API calls work.

Seriously, guys, just fix this already

Local 6.4.3+6116 / Win 10 Pro

Just wanted to note I’ve had this issue for months now as well.
Latest version of Local on Windows 11.

Hey @alexwright - this thread is about Windows specifically and the UI not reflecting the accurate SSL trust status. This has been fixed with a previous Local release (Local 6.5.1).

Here is a recent reply for SSL troubleshooting - SSL certificates no longer work in Google Chrome - #42 by austinwendt. If you update to the latest Local and are still experiencing the issue after following the steps in the link, please reply in that thread and we can take a look.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.