SSL not working

Windows 10, local version 2.2.1

SSL not working, when I press “Trust” button changes to “Trusted” but still can’t access https even when exception added (white screen) further more when I try to navigate from SSL tab to any other (DATABAS for excample) and go back to SSL certificate status resetting to “TRUST” again. So it’s not saved.

It worked on stable version however, even with this strange behavior (button status turned back to TRUST after navigation). I updated because got 500 error when creating site from blueprint…

1 Like

I restarted PC now https seams to working, but it’s soooo slow. Seams like resolving hostname taking to long.

Well after another restart it working again, no problems with speed but still

1 Like

I have the same issue

Also it seams that order how you start local virtual host is important. If you want functional SSL you need first start site, then immediately go to SSL tab and enable TRUST, only after that go to https://somedomain.local if you try to visit URL before enabling SSL https will not work (browser alert will be triggered).

Still trying to figure out everything. Will post updates if find out more.

Yup, SSL is not working for me either on Windows 10.


What issue are you running into specifically?

Have you tried restarting your browser after clicking the “Trust” button?

Also, on the flywheel app I go to SSL and hit trust and then it gets a certificate certUtil.exe
then it says Trusted on SSL and I open the site in my restarted browser and it still says in the
browser i testone.local/ and then I go back to the flywheel app go from SSL to site setup and when
I go back to SSL the trusted is gone and it says trust again???


I replied to you in SSL issues on windows 10, cURL error, new install. Please continue our discussion there if possible. :smiley:

I have this issue too, the lack of support on this issue is ridiculous!

As I said, just do it in right order.

  1. Create site.
  2. Enable TRUST, ignore fact that it will show TRUST again after you pressed it.
  3. Go to https://yourlocaldomain

Don’t go to http first.

1 Like

Unfortunately your solution doesn’t work, you also need to factor in that we already have sites created that were working fine and now flyweel has updated and they don’t work any more

If anyone is still running into issues regarding HTTPS/SSL/TLS, please provide screenshots of what’s happening. It’s a fairly broad term in this case so it’s tough to know what’s going on without more details.

This is happening when I update WordPress and any plugins. See screenshot. I’m running Local Version 3.2.1. SSL works but I can’t update anything.