SSL Trust not Remaining Trusted

Hi there,

On Windows 10. Using Chrome latest build.

When in Local > SSL I click the Trust button and I’m asked whether I want to allow this cert to be trusted. I type in my admin password and the button now says Trusted and is greyed out. But when I go to another tab, like Utilities or Site Setup, and go back to SSL the Trusted button now says Trust and seems to be back to it’s default setting.

Also, even before I leave the tab and it resets to default, when I open the site it doesn’t auto-redirect to https, is it supposed to? If not, what am I supposed to do to make it redirect? Just edit the .htaccess file or…?

Some guidance would be appreciated.


The lack of support on this issue is ridiculous, I have this issue too!

Reached here for the same problem. Looks like it’s time to dump Local until basic issues are answered, if not resolved.
Windows 10 environment.


Sorry for the trouble! What version of Local are you running?

Also, what browser are you using?

Trusting the certificate does not set up HTTP to HTTPS redirection. It only bypasses the self-signed certificate warning in browsers such as Chrome and Safari.

If you want your Local site to use HTTPS, change the site URL and home URL settings under Settings » General in the WordPress admin.

Using Local version 5.2.5+2498. Also had the same issues with version 5.2.4.

I understand that I need to change the site URL and home URL, this issue was not present in the slower Local by Flywheel, this is only happening since the Lightning version was launched.

This is a major issue, please look into it if you can @clay

1 Like

I am also experiencing the same issue… I trust a site, it says its trusted but when i click away and back in, the site is NOT trusted. I used to be on the old Local by Flywheel and after “upgrading” to the lightening version, this problem has started… can we all please get some help with this quickly?

Same issue here. browser is Firefox and local lighting version 5.6.3+4270. At the top of the screen a message is shown “HEADS-UP! Your site is using HTTPS but the local SSL certificate isn’t trusted.” No matter how much I use the trust button, local lightning keeps having trust issues.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.