Local Community

Stopping Site in 5.x Shows a Mysqldump error

I get the following popup whenever I stop my site in Local on 5.x. This doesn’t happen in the older version of the app, and I can’t move to this one until I can start and stop the site without errors.

Has anyone seen this error before? I had to import the database from live using mysql cli as it’s too large to use adminer (and modifying the php.ini, which lets me use adminer on the old Local, no longer increases the memory limit for me in 5.x). I do have some non-WP tables in there – could the process be choking on that? Is there a mysql log somewhere?


Just to add, I tried lightning again today and got the same error. Found the lightning log and saw this (if it helps at all).

{"thread":"main","class":"","stack":"Error: mysqldump exited with non-zero exit code.\n    at exports.default.<anonymous> (%%appPath%%/main/sites/database/SiteDatabaseService.js:1:1740)\n    at Generator.next (<anonymous>)\n    at o (%%appPath%%/main/sites/database/SiteDatabaseService.js:1:124)\n    at processTicksAndRejections (internal/process/task_queues.js:85:5)","level":"error","message":"Unable to dump database.","timestamp":"2020-09-05T23:12:51.102Z"}

What command is being executed under the covers for the sql dump?

I figured it out. The mysqldump message I got when I ran the command manually in the site’s shell was complaining about the definer being invalid when lock tables are selected. I found some offending views and modified their definer manually to local@localhost and that appears to have fixed the issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.