Local Community

The FlyWheel local site will not load, produces error 10054 and 10061

Issue Summary

Flywheel works fine on my Windows 10 but on Windows 11 I can’t get the local website, or anything (WP admin etc) to open. Both machines have the same antivirus set up (Avast Premium). I have tried deactivating Avast and Windows defender. I have started Flywheel in admin and in my local username with same result. Started restarted the machine made and remade projects

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    6.22 and version before
    Tried various combinations of mysql and PHP, still get the same result

Windows 11 Home

Edition Windows 11 Home
Version 22H2
Installed on ‎22/‎04/‎2023
OS build 22621.1702
Experience Windows Feature Experience Pack 1000.22641.1000.0

the router error log
2023/05/24 07:16:59 [error] 4492#8872: *1 WSARecv() failed (10054: An existing connection was forcibly closed by the remote host) while reading response header from upstream, client: ::1, server: exp2.local, request: “GET / HTTP/1.1”, upstream: “”, host: “exp2.local”
2023/05/24 07:17:01 [error] 4492#8872: *1 connect() failed (10061: No connection could be made because the target machine actively refused it) while connecting to upstream, client: ::1, server: exp2.local, request: “GET /favicon.ico HTTP/1.1”, upstream: “”, host: “exp2.local”, referrer: “http://exp2.local/

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi there @dhmharris -

You mentioned you’re using Local 6.22 (unless that was a typo!)

Have you considered updating Local to the latest release (6.7.2)?


very sorry. That was the Word press version. The Flywheel Local version is 6.7.2

Hi there @dhmharris -

Got it! Are you using nginx or Apache as the server?


I am using nginx. Everything is as if it has just been installed, so the default of how it comes. I have used different version of php and mysql in the past to see if it made any difference, but it didn’t. I also shifted from site domains to local host as well because I found that in a forum

Hi @dhmharris

Can you share your full Local Log with us? Retrieving Local’s Log File

Sorry for the delay. The download log button does not appear on the version I have, but I hope these two files are what you need.

local-lightning.log (208.9 KB)
local-lightning-verbose.log (674.5 KB)

Hi @dhmharris

What about other developer applications? Are you running any simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

If you change your Router Mode, does that allow the sites to open? Router Mode

I don’t have anything else running at the same time, like the apps you mentioned. However, this machine is a former display model which I bought cut price. I wonder if the vendor left anything on it which was needed in the store and which might run in the background? I have tried running in both router modes with the same result, i.e. nothing. I also do some part time editing and use a software package called TexStudio which allows PDFs to be edited. This package doesn’t work on this machine either. I wonder if its the same underlying issue.

Hi @dhmharris

Here are some other steps you could try to see if something is interfering:

  • Stop all sites that are running in Local

  • Force quit Local

  • Run the command netstat -ano

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process. (On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process)

After that, you should be able to retry. Keep us posted if you have any questions or continuing issues.

1 Like