Timeout Connecting to DB via Sequel Pro

Hey party people. I’m getting a timeout error when using the one-click Sequel Pro feature. Here’s the error message.

Unable to connect to host, or the request timed out.

Be sure that the address is correct and that you have the necessary privileges, or try increasing the connection timeout (currently 10 seconds).

MySQL said: Can’t connect to MySQL server on ‘’ (4)

Any ideas?

Got a pro tip from a friend. I went to Help -> Restart Local Machine and the problem was resolved. Much love, Clay!

1 Like

I’m having this same problem. I can’t connect to MySQL with Sequel Pro to save my life. I’ve tried setting up sites with both MySQL 5.5 and 5.6 all to no avail. I keep getting this 10 second timeout error. I’ve tried restarting the local machine too. I don’t know where I’ve gone wrong. I even logged into the VM over SSH to look at the /etc/mysql/my.cnf file to see if remote connections were getting blocked, but everything seems ok. The mysql user table has a user for root with a host of %. So that all looks good too. Anybody have any ideas? Thanks in advance :slight_smile:

Sorry for the trouble!

Are you using the IP to connect that’s supplied in the Database tab?

Yes, I was using the IP to connect with a “Standard” connection in Sequel Pro (not socket or SSH). It’s the darndest thing. It just times out every single time no matter what I do. I have MAMP Pro installed because that’s what I have been using, but was hoping to migrate over to Local. Everything works really well except this Sequel Pro thing. I can’t think of any way MAMP would be blocking anything, but I suspect I’m just being stupid about something since nobody else seems to be having this problem.

I’m assuming you tried the one-click connect button in the Database tab and that failed as well?

Also, when using the IP you put in the non-standard port (not 3306)?

Sorry to ask the obvious, but gotta make sure the bases are covered :slight_smile:

Yes, I used the one-click Sequel Pro button in Local. The port was 5001. Thanks so much for the help. Maybe I’ll just try reinstalling the whole thing. Perhaps that will make a difference. Thanks again.

Just putting the solution that works for me here for others to give it a try.

Sequel Pro > Preferences > Network
Change ‘Connection Timeout’ to something more than 10secs ( I used 30secs)


1 Like

For some reason this came up today, connections taking longer than 10s, but this worked!