Too Many Connections Error

This is very frustrating when you are trying to show a client their site and they get the below message. I have not found a resolution to this issue. Please help. thank you.

Too Many Connections

Too many connections! The tunnel session ‘1P0b0p1hnAd4N002Fe29djwInsP’ has violated the rate-limit policy of 20 connections per minute by initiating 26 connections in the last 60 seconds. Please decrease your inbound connection volume or upgrade to a paid plan for additional capacity.

The error encountered was: ERR_NGROK_702

1 Like

Hey @designbykeri

Right now the tunnel provider (ngrok) has a limit of the number of connections or resources loaded in a given time. So, if you have a page with a lot of links to images, stylesheets, or scripts, you can go through the limit quickly.

Improving Live Links is something that we are wanting to do and are still working through the best way of going about this.

In the meantime, you have a couple of options:

  • Make use of a plugin to minify and/or lazy load assets so that the total number of assets is reduced for the various pages. Autoptimize should help with this or a more advanced caching plugin like WP Rocket would also help.

  • Deploy a version of the site to a Demo site so that there aren’t any limits on the number of assets that are downloaded