Uh-oh! Could not update hosts file Local ran into a problem when trying to update the hosts file. Please ensure that the hosts file is not locked by anti-viruss

What issue or error are you experiencing?

i keep running into this error " Uh-oh! Could not update hosts file

Local ran into a problem when trying to update the hosts file.

Please ensure that the hosts file is not locked by anti-virus."


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

i have read similar articles with the same issue

  1. i’m not running other developer applications simultaneously eg XAMPP, or Docker. Neither have i downloaded any of these applications
  2. i did not install or activate any antivirus, security, or firewall applications
  3. i just downloaded local yesterday so i’m pretty sure its up to date and of the latest version

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    Operating system mac m3 chip


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @graceleese

Is this a work machine perhaps? Sometimes if a piece of equipment is issue by your employer it will come with certain apps or programs that might restrict access.

Could you share your full local log with us as well? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

I am on a MacBook Pro M1 Pro and experiencing the same issue. It’s a fresh OS but still keep getting this error.

Hi @abdnafees

Have you checked for all of the above-mentioned culprits? Do you have any antivirus, security, or firewall applications that could be blocking Local? Are you running other developer applications simultaneously? Is this a machine issue by your employer?

I don’t know how I solved it but my setup works now. :slight_smile:

1 Like

Glad to hear it @abdnafees! Thank you for updating us :green_heart: