Unable to get Lightning working on Mac OS


I’ve been using Local by Flywheel for some time now and I love it. When Lightning was released I installed it alongside Local by Flywheel and set up a couple of test sites. Although they worked fine (and were impressively fast compared to LbF) at the time it was still not possible to choose an Apache server, which I need to be able to do, so I continued working with Local by Flywheel.

Recently I saw that Lightning had been updated with Apache now available and I’ve subsequently tried several of the latest versions, including 5.5.3+3667 today. However, with previously made Lightning sites, and with new test sites in Lightning using both custom blueprints and preferred settings, there are issues:

The system has to modify my hosts file each time I fire up Lightning, which then renders sites built in LbF unavailable until the hosts file is modified again, I presume to revert the previous changes. Is there a way that the hosts file could be handled which would allow both to run side by side without needing to constantly edit the hosts file?

Note: for the points below I am only running Lightning, having quit out of LbF.

Using Lightning, after allowing the hosts file to be changed as requested and with LbF not running, I’m now unable to access or view any sites - pages try to load initially with e.g. /?cache-buster=1862 appended to the URL, and it either spins forever or I get ‘the connection was reset’. If the cache-buster string is removed I get the same error. Same for admin and front end.

It doesn’t seem to be picking up sites which have been trusted for SLL either and isn’t serving them as https. If I amend the URL to be https I get Secure Connection Failed with PR_END_OF_FILE_ERROR

This is incredibly frustrating as I’m very keen to start working with Lightning, it’s so much faster than LbF, which has been crawling along on some sites, at times painfully slowly. Any help in sorting this out will be gratefully appreciated.

I’m running MacOSX 10.14.6 Mojave and primarily Firefox (latest) although also Safari and Chrome (latest), with similar error messages in each. As far as I know my system is the same as when I first tried Lightning a few weeks ago, when it ran well but didn’t offer Apache.

Hey Jem!

I would recommend closing Local Classic (Local By Flywheel) and then setting “Router Mode” to localhost in Local Lightning. This setting can be changed under Preferences -> Advanced. This should bypass the need for Local to look to your host file and might provide a way for you to test that Local Lightning has all of the features that you need for your dev work.

It is worth noting that running Local Lightning and Local Classic in parallel isn’t specifically supported. So while this may work under certain conditions, it isn’t guaranteed that you will be able to use both simultaneously.

More info on Localhost router mode can be found here: https://localwp.com/help-docs/router-mode/


First I should say that running both side by side is not a priority, though it would be nice. The errors I’m getting all occur when Lightning is running alone.

Secondly, I just tried the change you suggested but I’m still having the same issue - connection reset. I’d prefer to work with domains rather than localhost too.

I’m confused as I had Lightning running some weeks ago without issue, except it didn’t offer Apache. That was when I spun up most of the sites I’m trying to access now, although some are recent installations. All the latest versions of Lightning I’ve tried over the last few weeks have produced the same error and don’t allow access to admin or front end.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.