Never been able to use Local (Lightning)

Hi Local people:

I’m using a mac with Mojave (haven’t upgraded to Catalina yet).

I’ve used Local by Flywheel for almost three years now. I’m currently using v 3.3 - one of the things I love about this tool, is that I don’t have to mess with any backend stuff… I just go in, start up a site, and begin working on it. But now seeing the new(ish) “Local (Lightning)” and I’d really like to switch to it, but no matter what I try, I’ve never been able to get the newer Local (Lightning) working. All versions (I just downloaded and tried Version 5.5.3+3667). Still no go. I ALWAYS get this error:

" ! Heads-up! Local’s router is having trouble starting. Learn more" (RETRY) "

(Learn more is a link, RETRY is a button). I tried reading the “learn more” page but the option to change router mode isn’t available. And retry does nothing - I still get the error.

Also, and because I was curious, I also tried to start a brand new site in Local, but I get the same error.

And on another note: When I try to use Local Lightning, it then messes with all my sites in Local by Flywheel, and the only way to go back to that, is to delete any sites I have in Local and make sure it’s NOT running. Note that the error in the site(s) on Local by Flywheel is:

“Warning! Missing hosts entry. This site may be inaccessible. (FIX IT)”

(Again “FIX IT” is a button)

I click the “fix it” button, and then it fixes it and I can continue work on the sites in Local by Flywheel. If I try to add a new site in Local again, it messes with the Local by Flywheel sites.

This second problem happens in reverse as well. If I go back to Local, I get the same missing hosts entry, but then once it’s been ‘fixed’ we’re back to the first error with the local router having trouble starting up.

I’ve tried to use Local Lighting every version you’ve had come out. I’ve read every post with the same (or similar) errors, and still no dice. I’ve had to go back to Local by Flywheel every time because I have client work that needs to get done. And I’m starting a new client website build this week, so I really don’t have time to try and figure this out.

Because I have client work to do, I am still using Local by Flywheel for now. I would really like to know what’s causing the problem with Local Lightning.

I’m also fairly novice when it comes to terminal / command line stuff, and also with what’s in the error logs - really no idea what any of that is (like what I see you others putting in here…) but I need help.

Lastly, right now I have some critical client work that has to get done, so for now, I’m going to delete what I did in Local, and just go back into Localy by Flywheel, fix the error, and get back to work.

Hopefully someone will be able to help me figure out what’s going on so I use Local in the future…

Hi there,

:robot: Thanks for being a longtime Local user! :green_heart:

While you can have both Local Lightning and Local Classic installed on the same computer, you can’t use them at the same time. (You can switch back and forth, but they can’t be open at the same time.)

The “Local router can’t start error” is a sign that a different software or process is using ports 80 or 443.

Here’s a few tips on migrating to Lightning:


I’ve read that article before but it didn’t help.

I’ve never run them at the same time (i.e. they’re both installed, but i don’t open them at the same time). I just assumed that you guys knew that I would never have them both running at the same time. I have one shut down while I run the other, and vice versa.

And the whole thing about “ports” and such… I don’t mess with those (I’m not saying that you said I did)… I just have no idea about that side of things (I’ve only marginally messed with terminal / command line on some things, but I never really understood what i was doing, so I tend to shy away from that side of things). But that comment about it being a sign that a different software or process is using ports 80 or 443… makes me wonder… is there some sort of process in Local by Flywheel that would run in the background even if the main software itself is off? Virtual box maybe? Again, I have no idea what any of those command things do when I’m peeking around in terminal…

How would I check to see what else may be running on those ports? Is there a command or something I would put in terminal to check? Or where else should I look?

~ Tracy

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.