Local Community

Unable to install plugins

I have the following error message on all pages I create in LocalbyFlywheel:

"Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. server administrator.) "

I immediately find the warning under “Settings - General” at the top when I have created a new site.
Likewise, the warning appears when I try to install a plugin, which I can not.
It all seems fast, but when I try to use the Plugin and Settings menus, run it incredibly slow.

My installation is: Local-by-flywheel 2-2-4.
Installed on PC with Widows 10.

I have repeatedly uninstalled and installed Local-by-Flywheel. The problem occurs every time.

I have done as you recommend to correct the error, but it does not help.

As you look at attachments, I get some text in red, which I do not really know what to do with.

Can you please help?Udklip-2Udklip-3

Hey @Erling

Usually the error:

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. server administrator.)

Has to do with the site being unable to connect to the WordPress.org server. This could be a temporary thing, or it could be some piece of software that is blocking that connection – perhaps an AntiVirus software, or maybe a firewall in your local network.

You mention that you have “done as you recommend to correct the error” – can you link to those instructions so that I can see the context?

I’m not sure, but it’s possible that those commands only work in CMD.exe and not in Powershell.

To rule out if this is a network issue – can you try this from a different network – perhaps at a local coffee shop?

– Ben

Hi Ben!

Thank you very much for your answer.

You just get the link here: Help! My Local site cannot establish a connection to WordPress.org

I have also tried to turn off protection (Kaspersky Internet Security).
Then, Defender, which has been switched off, will pop up and will block, but I reject it so it should.

I have it with my PC, as with my car. I’m totally lost when I open the engine or when others speak technical details about gearbox or the like.
Going into Powershell is the only solution I can see immediately.

How do I fix commands in CMD.exe, I do not know anything about.
I do not even know what CMD.exe is or where I find it.

To switch networks.
I have now tried that and -
It works! Hooray! Hooray!

As an emergency, I have mobile broadband.
I have tried this now, and so does Local by Flywheel seem perfect?

I’d rather use my normal broadband as it runs fast, but it’s obviously the fault here, so much thanks for the help.
Hope you might be able to help?

My router is: TP-Link Archer C2600.

Well, at least we know that it has something to do with the network.

I’m afraid I don’t know enough about networking and there are so many possible settings, that I wouldn’t know where to start troubleshooting why this isn’t working for your local router. Maybe there is a setting when you login to the router that is preventing you from accessing the WordPress.org site?

Hi Ben!

Yes, it must be either in the router or by my broadband provider.

I’ve looked in the router if there should be a barrier, but did not find anything.
Will try again.

Likewise, I will contact my broadband provider for assistance.

If I find a solution, I will write it here, so others with the same problem have a place to begin.

Thank you very much for your help.
Now, at least, I can work in Local by Flywheel, which really is a win for all of us.

I forgot to tell that I have used Desktop Server (ServerPress) without any problems. Here, WordPress worked normally.
It just makes the problem stranger that it works on Desktop Server, but not on Local by Flywheel.

@Erling,

I’m fairly confident that if you change the NAT settings it will fix the issue.

To run the commands in Cmd.exe, simply open “Command Prompt” like you did with PowerShell. Run the commands exactly like you did before. Copy and paste them and then press enter to run them one by one. :slight_smile:

Thank you Clay!
It worked immediately.
I am very grateful.
It’s always hard to be ignorant of one thing you use as a tool.
Fortunately, there are people like you - to help people like me.

I’m having the same issue but I’m on a Mac. This is the 4th site I’ve installed and the only one I have had this problem on.

Hey @eno

Can you describe the issue you are encountering in a little more detail? What steps have you tried to fix it?

If you are still having issues, are you seeing any errors? If so, can you take a screenshot and show us what you are seeing?

– Ben

Every time I try the cmd solution for windows (Help! My Local site cannot establish a connection to WordPress.org), it just kept saying “The system cannot find the path specified.” What am I doing wrong?

Hey @pahafer

The steps outlined in that forum topic are for the Local Classic application, which used Virtualbox to manage WordPress sites. With more recent versions of Local, that dependency doesn’t exist.

Have you tried other networks to see if that allows you to install plugins?

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi @ben.turner !

Thank you for the response. I have not tried other networks but I don’t really have any option anyway. See the attached file for the Local log. local-lightning.log (73.9 KB)

Hey @pahafer

There is an odd error in the Local log that seems like it could be related:

  "thread": "main",
  "reason": {
    "message": "Couldn't find your IP",

How are you connected to the internet – is this a home wifi setup that you created, or is it some existing network? Is it a work network with any security settings in place? What about a vpn – is that being used?

Hi @ben.turner

It is a home wifi network I set up. Although I’m connected through LAN. Do you think that’s related somewhat?

It could be. When the network was set up, were there any security settings that were put in place? For example, anything that might be preventing access to remote sites?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.