Local Community

Unable to open single Local site after Updraft backup

Went to open my Local test website today noticed 5 apps needed updating. Elementor was one of them, however my Local recommended backing up before updating, which I did using Updraft Plus. When that had completed and at that point I need to go out so closed everything down, apps and PC.
On return I again tried to open my Local Test website, there followed a series of Errors,‘RBC/Local/ Error establishing a data base connection’

I have tried looking through the Help pages, but I do not know where to start even trying to fix this error. Google searches gives more confusion. SO, I am hoping one of you kind souls can point me in the right direction.
I cannot get past the opening screen, tried all options I could find. I am an OAP and a real newbie at this so please bear this in mind.
My grateful thanks for any help you can offer.

One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.


We would be happy to assist with your Local troubleshooting! Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

Hi Nick Thank you for your reply, I am using Windows 10 Pro, fully updated.
MY Local version is:

I hope that’s right!
I will have to search for how to find logs as there does not appear access from the front page as above.

Maybe I have missed something but I cannot find a way to access the logs unless I get past the front page?
I have not tried to make a new Local website, I feel this may cause more problems. However if I can, or do, make a new site is it possible to import the site I am having problems with?

Hi @ajw1100

If you go to this help article it will walk you through how to get your Logs.

Retrieving Local’s Log File

Since you’re on Windows - Do you have any antivirus, security, or firewall applications that could be blocking Local? That could be part of the issue.

More details about troubleshooting this here: Router Mode

local-logs.zip (37.9 KB)
Logs, attached, fingers crossed.
I am running BitDefender total security, I’ve had this for years and it has never caused a problem with Local or our club website or anything else, so reckon that’s okay. Quick explanation; our club webmaster lost his battle with cancer early last year, no one else volunteered to take it over so I got the job. My Local Test site is so that I can play and learn without screwing up our club site. Until today, no problem.
The router is also fine, BT’s best.
Read the info in Router Mode. Way beyond my understanding I am very sorry to say.

Well, blow me down with a feather! Re started my PC again this evening, and although I’d started it earlier today, Local Test opened properly :partying_face: :partying_face:
Don’t know how or why but I’m back in business.
Thank you Nick for your help, if nothing else with your help I have learnt a little more today.

1 Like

Hi @ajw1100 Glad to hear it! If you hit any other snags you know where to find us :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.