Unable to provision site - using blueprint

What issue or error are you experiencing?

I can’t create a new site based on a saved blueprint anymore. I have been doing this same process for years - since 2020! This is the first time I have encountered this error. I updated local today to 8.3.2 — I have always created a fresh new blueprint based on my “blueprint” website before using it. Once I have the blueprint created then I create a new site using this new local blueprint. Things I have tried: restarting my computer after updating local to 8.3.2 and deleting the blueprint and trying again. I do NOT get this error when creating a new site without using the blueprint—but again, I have used this method for the passed 4 years. What changed?

Dropbox - Screenshot 2024-03-19 at 10.30.11 AM.png - Simplify your life

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Create a new blueprint from a local site > try to create a new site using this new blueprint.

Retried many times with a fresh blueprint:
Dropbox - Screenshot 2024-03-19 at 9.48.17 AM.png - Simplify your life
Dropbox - Screenshot 2024-03-19 at 9.13.48 AM.png - Simplify your life
Dropbox - Screenshot 2024-03-19 at 10.40.28 AM.png - Simplify your life

System Details

  • Local Version:
    Updated today to 8.3.2

  • Operating System (OS) and OS version:
    Sonoma 14.2.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @angelaschmidtdesign

As a test if you downgrade your Local version does it start working like it did it previously again?

Hi Nick,

Yes! I can use blueprint again on version 8.2.1 but NOT 8.3.1 or 8.3.2 - hope this helps!

One more thing could you click the Download Local Logs button from the Support tab in Local and share that zip here? This will generate an archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering. Thank you!

local-lightning.log (506.2 KB)

Is this what your looking for?

Hi @angelaschmidtdesign! What we’re looking for would be from this:

I tried replicated the issue this morning using Local 8.3.2. I spun up a preferred site, created a Blueprint, and then tried to create a new site based on that Blueprint but it worked just fine for me. We can take a look at your logs though and see if anything stands out!

local-logs.zip (462.3 KB)

Something to clarify here is this just happening when you try to make a blueprint of a specific site? Or for example if you try to make a blueprint of a different site or a new site does the same thing happen?

I can’t use a blueprint from any of my current sites, but I can use a blueprint from a “blank” or new WP site on local.

As a test could you try cloning, or exporting and reimporting one of the sites where the Blueprint isn’t working, and then on the new clone/import see if you can create a Blueprint and proceed from there?

Nope, it gets “stuck” in Provisioning and Changing Site Domain. I quite local and opened it so I could continue, but no I was still unable to create a newsite using a blueprint from my cloned site.

Hi @angelaschmidtdesign

Thank you for your patience! We’ve been looking at this from our end but haven’t been able to replicate it yet so we may need some further help.

As a test could you try these steps?

  • Create a Blueprint using Local version 8.2.1 (where it works)
  • Export that Blueprint
  • Upgrade to Local 8.3.2
  • Import the saved Blueprint back into the updated Local and try again

If that doesn’t work, we’d love to get a copy of one of your sites to be able to test further from our end. You could export it and save it to a Google Drive or Dropbox link we could collect over DM to be able to troubleshoot.

Keep us posted and we’d be happy to help further!

1 Like

How can I export the blueprint? I don’t see this option.

Apologies there I messed up those steps a little bit! What I intended was for you to create a site from that blueprint, export the site, reimport, and then use that to create a blueprint on the new Local version.

Nope, it will not let me import the site. How do I DM you the site?

I’ll reach out here!

FYI - I’ve been having the same exact issue. I have downgraded for now but if there is any help I can provide, let me know.

Thank you for these reports, @angelaschmidtdesign and @mwhiteley16. I’m sorry you ran into this with Local 8.3.1 and 8.3.2.

I’ve been able to import both the blueprints that @angelaschmidtdesign shared with Nick-B under Local 8.3.2 so far.

I’d love to better understand what’s causing this, though. When you next see a message like, Failed to open required defaults file: /Users/username/ Library/Application Support/Local/run/d7ufFPjuW/conf/mysql/my.cnf, please could you check and share the following before you click “ok” to dismiss that message?

  1. Does the file named my.cnf (or the equivalent for PHP errors) exist at that reported path in your filesystem? (Feel free to share a screenshot of anything you do see at that location.)
  2. If you open the Finder and choose Go → Go To Folder, then enter the path below and press enter, please could you share a screenshot of the directory with the same mysql-[version-from-your-error-message] in list view with folders expanded? For example, mine is below.

Path to enter into Go → Go to Folder for step 2:

~/Library/Application Support/Local/lightning-services/

Screenshot of directory contents:

(I’m asking this just to check whether Local is downloading and copying the MySQL/PHP configs correctly for you or not.)

Solved for me: I had the same error as shown in the screenshots whenever trying to clone (did not use a blueprint) and my Users/username/ Library/Application Support/Local/run/RANDOM_STRING/conf folder was empty each time. I downgraded all the way to 8.2.0 and nothing worked. Then I toggled the PHP version of my site I was cloning from from PHP 8.0 to 8.2 and cloning worked again! Re-upgraded to Local 9.0 and it still worked!

1 Like

I can confirm that switching from 8.0 to 8.2 in the blueprint I was using does resolve the issue. I didn’t have a chance to check the logs for those other troubleshooting steps, but hopefully this provides insight as it seems to be 8.0 (or maybe <= 8.0) PHP version causing the issue somewhere along the line.

Thanks Rich!