Update of WP to 6.5.4, site cert for local no longer trusted

I have been developing a site w/o issues. Today, WP wanted to update to 6.5.4. Updated local and now I am receiving site unsave issues.


Closed the site. Reopened the site, will be run secured.
Rebooted the system and situation still exists.
Firefox also shows as an unsafe site.

System Details

Local Version 9.0.3+6684

Laptop: |Edition|Windows 11 Home|
|—|—|
|Version|23H2|
|Installed on|‎7/‎2/‎2023|
|OS build|22631.3672|
|Serial number|PF18W3N9|
|Experience|Windows Feature Experience Pack 1000.22700.1009.0|


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @jcisintucson

Have you tried any of the troubleshooting steps here?

I re-read the SSL in Local doc had copied the URL to Firefox and had the same issue. I noticed that while the site has Trusted selected, Local is sending http://nutritionals.local/wp-admin/ to the browser instead of https://nutritionals.local/wp-admin/.

So, how do I fix the issue that Local is not sending https://? Is there a way to reset the trusted flag to see if there is some other issue?

Yep! I would double check that your browsers are up to date, and then delete the certs manually and try again.

On a similar bug we had in the past we had some steps posted here that might be helpful:

I found a Certificate file located in c:/Users/[username]/Local Sites/[site]/app/public/wp-includes/Certificates

I removed that directory and restarted Local. No change.Looks lie I cannot upload a video of the new site I created and even though it says it is trusted, it is still started as http://

Did you check your browsers to see if there were any updates in there?

Have you done a full purge of cache and cookies in those browsers?

Yes, cleared cache and cookies.

I had also attempted to use firefox to run the site with the same results. Local is actually sending http:// instead of https://. If I copy the url and then paste it and change the http:// to https:// then is works. I also attempted to create a new test site, which should not appear in the cache. I trusted the site and it still attemptsed to open the new test site as http://.

To confirm is your Router Mode set to Site Domains?

Preferences>Advanced>Router Mode