Updated to 2.0.4 and now local gets stuck in a loop starting up


Just upgraded to 2.0.4 and now my local just says:

Checking System…

Regenerating Docker Machine TLS Certificates

And continues to loop the loop. Tried the following:

Still does it so I can’t use it anymore. Any suggestions?

Can’t locate the log so cannot upload (mac)



Oh and i’ve also tried:

docker-machine regenerate-certs local-by-flywheel

Hi Simon,

Very sorry for the trouble!

You can find the log here: ~/Library/Application Support/Local by Flywheel/local-by-flywheel.log

Thanks Clay - not your fault :slight_smile:

OK i’ve no log file in that location, I do have the following files listed though:


Ah, sorry! Not sure why I mentioned that path :slight_smile:

It’s ~/Library/Logs/local-by-flywheel.log

Maybe it’s your age :slight_smile:

1 Like

Heres the log file - Dropbox - File Deleted - Simplify your life


1 Like

Haha, maybe :slight_smile:

Thanks for the log!

Do you know what version of VirtualBox you’re on? You can check it by going to VirtualBox » About VirtualBox. I believe I’ve seen this problem be solved by upgrading VirtualBox in the past.

It’s currently Version 5.1.4 r110228 (Qt5.5.1) - i’ll try upgrading to see if that resolves it and update here shortly.

Alas no, still doing the same thing - log file updated with the latest on the same link

Now that you’ve upgraded VirtualBox can you try the following?

  1. Quit Local if it’s running
  2. Go to Terminal (or your preferred terminal app)
  3. Enter "/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" kill local-by-flywheel
  4. Open Local

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Okay, can you try these in Terminal now?

  1. "/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" restart local-by-flywheel
  2. "/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" env local-by-flywheel

After running them please copy and paste the output here.

$ “/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine” restart local-by-flywheel
Restarting “local-by-flywheel”…
(local-by-flywheel) Check network to re-create if needed…
(local-by-flywheel) Waiting for an IP…
Waiting for SSH to be available…
Detecting the provisioner…
Restarted machines may have new IP addresses. You may need to re-run the docker-machine env command.

$ “/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine” env local-by-flywheel
Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: tls: DialWithDialer timed out
You can attempt to regenerate them using ‘docker-machine regenerate-certs [name]’.
Be advised that this will trigger a Docker daemon restart which might stop running containers.


Are you running a VPN, proxy, etc?

I’ve got Hamachi VPN running but thats always been the case. No proxy i’m aware of. Hamachi currently powered off.

1 Like

One more command to try for now:

"/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" upgrade local-by-flywheel

After that, you can try relaunching Local.

Been running around 15 mins so far, seems to be stuck on the following:

$ “/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine” upgrade local-by-flywheel
Waiting for SSH to be available…
Detecting the provisioner…

Still running so killed it, obviously didn’t like that command :frowning: Couldn’t reply back as the forum locked me from posting for 24 hours :frowning:

Hey Simon,

Can you run this command real quick? It’ll check the hash of the ISO that the Docker Machine is using.

md5 ~/.docker/machine/machines/local-by-flywheel/boot2docker.iso

For reference, this is what the hash is on my machine with 2.0.4: 57ee4780245e8b52cdee5b1836fece74