Updated to 7.0.1+6387 and get localhost:####

Issue Summary

I updated to Local version 7.0.1+6387 today trying to test and solve an issue on a client’s site and can see my list of sites along the left, but cannot get any to open. I get the message “Secure Connection Failed An error occurred during a connection to localhost:10282. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG…” for the site I tried to import into flywheel to test.

BUT also no site url has the site name in the URL, they have localhost:###

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? All sites show up with the url localhost:### where before they had the site name, and the sites themselves don’t open, instead I get “Unable to connect”

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? yes, but it doesn’t have the site name, it has “http://localhost:10312/wp-admin/” and once I import a site into it it no longer opens, see response to the first question


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them! It’s happening after I import a site file into flywheel local and try to open it. the live site is ok. It’s also happening when I try to open any site already existing within flywheel local.

System Details

  • Which version of Local is being used? 7.0.1+6387

  • What Operating System (OS) and OS version is being used? MacOS Ventura 13.3.1 (a)

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

local-logs.zip (859.2 KB)

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @TriciaI! It sounds like your Router Mode got changed from Site Domains to Local Host. Are you able to swap that back?

If you go to the bottom of this help article there is a short video for Changing Router Mode.

Thank you for replying!

I just did that, but it’s still showing as local:host### and has the secure connection failed notice. Also I’m now seeing a Warning in a pink banner across the top of the local colum on the right (where the overview database and tools tabs are located) that says “Warning! This site’s WordPress URL settings do not match the host set in Local.”

Hi @TriciaI Have you tried rolling back your Local upgrade yet?

Thank you again! I just tried rolling back to 7.0.0 with no luck (I know I was being optimistic) Will try 6.7.2 in the morning. (it still pointed to Local Host… and gave me the secure connection warning.)

1 Like

Hello. I just installed 6.7.2 and am still getting the secure connection warning and its still showing with localhost: in the url, not the site name, even though preferences are set to domain.

I exited everything and restarted my computer (and counted to 10 for good measure :slightly_smiling_face: ) after restarting I was able to bring up another site with the domain in the url. So I tried creating a new test site because I REALLY need to troubleshoot for this client, but just like whenever I did this yesterday on 7.0.1+6387 I see localhost: in the url and it says connection not secure.

I’m trying this in both Firefox and Chrome. Any ideas? I’m really frustrated and this client is too…

Hi @TriciaI

Sorry for your frustration here! You might find some tips on our help docs below:

We also had another user who ran into a similar error (Error code: SSL_ERROR_RX_RECORD_TOO_LONG) and eventually they boiled it down to a Port Conflict.

More on troubleshooting Port Conflicts here: What is Router Mode? - Local

Otherwise, to get nuclear and try to start with a clean slate you could give the below troubleshooting steps a try:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. Any sites can be reimporting using steps found here: Import/Export a WordPress Site - Local

I just followed the SSL Certificate on MacOS link and went through the process of “trusting” the certificate and am now getting a warning message: “Warning! This site’s WordPress URL settings do not match the host set in local.” TBH, I’m kinda scared to click on it because I saw it on another local site the other day and couldn’t get in to the site. I actually couldn’t move on to Step 4 of updating the URL because I saw this warning…

Any advice? Am I at the point of uninstalling and reinstalling and hoping I can open these sites back up?

Hi @TriciaI

If you want to save your site files, you can uninstall and reinstall. Just make sure you have them backed up somewhere and you can always zip, drag and drop them back into Local to re-import. Your steps would look like this:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.