Local Community

Cant open site

Issue Summary Hi, I’ve installed my site on Local using Wordpress Duplicator. When I click “open site” I receive: This site can’t provide a secure connection. In Overview: SSL Note: HTTPS is not available when using the localhost Routing Mode. Clicking “WP Admin” opens the site dashboard ok. How can I view the site? Thanks for any help

One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • _ Windows 10
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hello @mdavid - welcome to the Local community! :wave:

After reading your issue, I’m curious - have you tried importing your site into Local using this workflow below?

Let me know if you have tried that and still get the same results!

Thank you,

Sam

Hi Sam, Thanks for this.
Can you tell me if I can use Duplicator plugin to create a backup for importing to Flywheel Local.
This is what I did, when I try to open the site I get

This site can’t provide a secure connection

and the Local Overview for the site tells me:
SSL Note:HTTPS is not available when using the localhost Routing Mode

I chatted with Christopher from Flywheel support and he tells me

“some people just prefer having HTTPS enabled on development so they can get the content loading HTTPS before going live”
I don’t care about security when developing on localhost, but I can’t use Flywheel Local 'cause some people prefer having HTTPS - sounds crazy to me!

I don’t have a backup on Flywheel or WP Engine (I’m hosting with Fozzy, and have a copy on localhost using XAMPP), so what would you recommend I do?

Your help is much appreciated

"

Hi @mdavid -

Got it! It sounds like your Routing Mode is set to localhost - are you able to update that to Site domains?

Shared with CloudApp

Let me know!

Sam

Hi Sam,
Yes that took care of it. Now able to view the site on my pc, thanks for revealing Local’s options - none of the other support people mentioned it and I didn’t find this googling or in the documentation.
Now I’d like to view the site on my mobile, I enter HTTP://xxx.xxx.x.xxx:80/florapal.local (both devices are on the same wi-fi network and x is the IPv4 Address), but I receive 404 Site not found, “the site you requested does not have an associated route in Local”. Can you enlighten me on how to access the site on a mobile device.
Thanks for your help

Hi there @mdavid -

I’m glad that helped!

Have you tried out Live Links? That’d be how to view your site on a different device :smile:

Let me know if this helps,

Sam