Using a mySQL desktop admin tool - Connection issues

Hi, Not sure this is the right place to post but I’m trying to use MySQL workbench to connect to the local mysql database that’s been created using local. In fact, I’ve tried several (Sequel Pro was preferred but it seems it crashes connecting to mySql 8). I cannot establish a connection at all, either through standard TCP/Ip or using a socket/pipe method. Locally, WordPress creates a connection fine but it would be nice to have a good interface/UI to the database. Any steers in the right direction appreciated.

1 Like

Same issue here, socket connection isn’t quite working.

Not sure if related but I also tried using WP-CLI using the Site Shell option. I tried wp db cli and then got this error which seems to show the socket itself is not working as expected. The site itself is fine on the HTTP side.

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

This is using Local (Lightning) 5.6.3+4270. I’ve tried restarting the site, closing and reopening the app and all that. No luck so far.

Have you tried this? Unable to access database

It looks like afragen’s linked thread solutions (symlinking the sock manually from the site’s socket to /tmp/mysql.socket) worked for the wp db cli part, which indeed looks like a different problem.

It does not solve the Sequel Pro socket issue which shows the databases themselves but trying to access the databases is unsuccessful as they are all empty or never fully load. Each time you select a database SP throws up an exception dialog like this:


-[_NSInlineData isEqualToString:]: unrecognized selector sent to instance 0x6000002fde60

	0   CoreFoundation                      0x00007fff308bcbe7 __exceptionPreprocess + 250
	1   libobjc.A.dylib                     0x00007fff696945bf objc_exception_throw + 48
	2   CoreFoundation                      0x00007fff3093bc77 -[NSObject(NSObject) __retain_OA] + 0
	3   CoreFoundation                      0x00007fff3082144b ___forwarding___ + 1427
	4   CoreFoundation                      0x00007fff30820e28 _CF_forwarding_prep_0 + 120
	5   Sequel Pro                          0x00000001000587cd -[SPTablesList updateTables:] + 1338
	6   Sequel Pro                          0x000000010002f333 -[SPDatabaseDocument setConnection:] + 748
	7   Foundation                          0x00007fff32f120dd __NSThreadPerformPerform + 204
	8   CoreFoundation                      0x00007fff30840de2 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
	9   CoreFoundation                      0x00007fff30840d81 __CFRunLoopDoSource0 + 103
	10  CoreFoundation                      0x00007fff30840b9b __CFRunLoopDoSources0 + 209
	11  CoreFoundation                      0x00007fff3083f8ca __CFRunLoopRun + 927
	12  CoreFoundation                      0x00007fff3083eece CFRunLoopRunSpecific + 462
	13  HIToolbox                           0x00007fff2f46dabd RunCurrentEventLoopInMode + 292
	14  HIToolbox                           0x00007fff2f46d7d5 ReceiveNextEventCommon + 584
	15  HIToolbox                           0x00007fff2f46d579 _BlockUntilNextEventMatchingListInModeWithFilter + 64
	16  AppKit                              0x00007fff2dab5829 _DPSNextEvent + 883
	17  AppKit                              0x00007fff2dab4070 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1352
	18  AppKit                              0x00007fff2daa5d7e -[NSApplication run] + 658
	19  AppKit                              0x00007fff2da77b86 NSApplicationMain + 777
	20  Sequel Pro                          0x0000000100002454 start + 52

Are you using the Sequel Pro nightly? It’s needed for MySQL 8.0

Didn’t realize that was a thing, I thought Local would just work with the old one so that was my bad. But then I went down the major rabbit hole of why it’s a nightly build and not a release and why there hadn’t been releases for Sequel Pro in years. Well I guess at some point Local might add support for more apps through add-ons, now there’s Sequel Ace (a fork of Sequel Pro, which doesn’t work as-is either), among other apps out there.

Anyways, the nightly build works so I’ll have to remember that for my other computers.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.