Word Press URL settings Error when duplicating a site

What issue or error are you experiencing?

Hello, I have set up a WordPress site that I want to use as a blueprint. When I try to clone it, the process gets hung up, when I save it as a blueprint and create a new site from that blueprint, I get this warning:

“Warning! This site’s WordPress URL settings do not match the host set in Local.”
and on clicking “Fix it”, I get this error message (screenshot).

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

When I try to clone the site, the process stays stuck in endless loop. When I end it (via "end programs immediately) I get this error message when trying to open the new page.
Or when I make a blueprint from my site and make a new site from that, I can’t open the site and get the same error message instead.

System Details

  • Local Version:
  • Operating System (OS) and OS version:
    Mac OS Ventura 13.5.2

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
Thank you very much for helping me with this!!!

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @SonjaA

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

Are you able to create a new blank site in Local?

Could you attach a copy of your Local Log? Retrieving Local’s Log File

Hi @Nick-B ,
thank you very much for looking into this. I’ll admit that I just gave up and de- and re-installed Local. I had no other dev apps running, but this was the first time I tried this Local install (on a new computer) and the (blank) WordPress site I made wasn’t able to produce a working clone. I made another very basic WP install and tried to reproduce that and it also gave me that same mistake. So since everything I had done to it so far was pretty much click and have things installed, I figure there must have been something wrong with the basic Local install. So I deleted everything and re-installed and re-tried (same everything), and now it works. No idea what exactly was wrong. I’ll upload the log files (sorry, I thought I had before), but I’m good now. Thank you!
local-logs.zip (18.8 KB)

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.