Xdebug configuration changes in php.ini have no effect

Issue Summary

Changes to the Xdebug configuration in php.ini on my Ubuntu installation appears to have no effect.

Troubleshooting Questions

The exact same process and settings work properly on my OS X installation.


The PHP ini config file given by phpinfo() :

This file does contain the Xdebug configuration from my conf/php/php.ini.hbs and it does update when I make changes and restart. Settings:


The actual xdebug settings given by phpinfo() do not match the configuration, however:


I have also tried using the value “On” instead of 1 with no change.

System Details

  • Local 5.10.5+5403

  • Ubuntu 20.04.2 LTS

  • VS Code 1.57.1

Checking Local’s log suggested that there was another FPM instance already running. This was verified with “ps aux | grep php-fpm”. I killed the orphaned FPM instances, restarted Local, and the php.ini settings worked as expected.

Stopping the site from Local’s GUI does not seem to end the running FPM instance but that’s a different issue than reported so this one can be considered resolved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.