Local Community

Xdegbug v3 config

I’m new to local and was configuring xdebug with phpstorm.
It auto installed xdebug 3 which wasn’t working propperly.
After trying a bunch of stuff I got it working when changing a few php,ini settings:

old

xdebug.remote_enable=1
xdebug.remote_connect_back=Off
xdebug.remote_port="9000"
xdebug.profiler_enable=0

new

xdebug.mode=debug
xdebug.start_with_request=yes

And now it’s working properly ( I didn’t add the auto config of the add-on)
I’m on Ubuntu 21.04

More details here: https://xdebug.org/docs/upgrade_guide#changed-"xdebug.remote_autostart

3 Likes

Wow, thank you. Changing my ini file to these settings worked. Good grief it was a nightmare getting this to work with PHP 8.