404 Site Not Found when trying to view site

Hi, I have recently installed Local and have used it to successfully make my first site. I made a second website but when I clicked on the view site or admin button I get the following error message:

site not found
The site you requested does not have an associated route in Local.
If you continue to get this message after refreshing, try restarting the Local site.
If the error persists, check the Local Router Logs in Local by going to Help>>Reveal Local Router’s Logs.”

I tried restarting the site and I tried making new sites that got the same error message.

In the Router Logs I checked the Error file and it gave the following error: ‘No connection could be made because the target machine actively refused it’ and also ‘The system cannot find the file specified’

I checked the host files and all my Local sites are there, including the ones that are not working.

I am not sure if this is an issue with my antivirus software as I am just using windows 10 default Windows Security.

I am a bit of a novice and have just recently started doing webdesign. I use Local 5.2.1 and my operating system is Windows 10.

Thanks in advance for any advice.

Hi Ester,

Sorry for the trouble creating your first site!

Can you please provide the local-lightning.log file in your response? You’re already halfway there since you know where it is. :slight_smile:

Hi Clay,

Thanks for your response.

I have attached the file I think you mean.

local-lightning.log (51.2 KB)

Thanks for sending that over!

If you create a brand new site in Local, is it accessible? Also, if you change the router mode from “Site Domains” to “Localhost” (note, this requires Local 5.2.1 and newer) from Preferences » Advanced, does it change anything?

1 Like

I created a few new sites to see if they worked and they were not accessible before, but changing the router mode worked for me, all my sites are working again.

Thanks very much for your help!

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.