404 The site you requested does not have an associated route in Local

Been having a hard time getting things to work.
I turned off the firefox setting asking for the certificate which i just can’t get to work.
site will work for a few hours then refuse to load.
Did a fresh install and now i’m getting this page.

Havnt got a solution but Im having the same issue importing a functional export made in Local 5. Also creating a new installation using Blueprint gives same error.
Running W10, Chrome. No data in logs/error

i should add that by following the directions to open the router logs that there have been no new entries to the log since the 30th

@flyjack plz help!

Hi @CaribouCollective, Let’s get this figured out. :slight_smile: Can you please send over the following information?

  • OS version
  • Local version
  • Local Log (found here in the Local app: Help > Reveal Local Logs )

Thank you,

Hi megan.
Sorry for the delayed response, in order to best approach this seemingly complex installation I have factory reset my PC and updated to the most recent version of windows 10.
I also downloaded Local and set it up.
404 error is gone, however I still can not get local to run inside of firefox. (most recent version of ff)

@mwallace I have gone into the SSL tab and “trusted” the certificate. No Change.
Works in chrome and edge just fine.

Hi @CaribouCollective, could you try using a local domain that doesn’t end in .dev?
ie: “cariboucollective.local”

It looks like you might have HSTS enabled for that domain which could cause SSL errors in Local.

Hi there, @mwallace and @flyjack, I’m also receiving this error after pulling a site into Local. Please help.

Windows 10 Pro 1903
Local 5.06+976
Logs attached

local-lightning.log (111.4 KB)

Me too - first site created yesterday, and after resolving hosts issue, works great. I have created a second site numerous times today and am getting the 404 error. At times the first site gives me a database connection error when starting, but mysteriously fixes itself eventually
Running Windows 10 Pro
Local 5.06+976
Router error log shows:
2019/10/23 21:29:22 [alert] 20496#10504: OpenEvent(“ngx_master_22488”) failed (2: The system cannot find the file specified)
nginx.pid shows 20244
local-lightning.log (103.6 KB)

Update today - I closed Local (again after leaving overnight), re-opened, tried yet a 3rd site that I had created, got the 404, started the first site and finally got it running again, still getting a 404, but the router error log has a different error so I have attached the log.
error.log (1.9 KB)
PID file has 24876 in it.

This is very frustrating

For anyone still stuck, try restarting your system. That fixed it for me.

I looked in the logs, and there were multiple errors trying to connect (as I tried starting the server multiple times):
No connection could be made because the target machine actively refused it

Hope this helped someone else.

For windows users:

If you go to this directory:

In there you will see a file called “route.{site_name}.local.conf

It should contain the following (Replace {site_name} with your site’s name, replace {site_port_number} with the right port number):

server {
	server_name {site_name}.local *.{site_name}.local;

	include server-block.conf;

	location / {

		include location-block.conf;

server {
	server_name {site_name}.local *.{site_name}.local;

	ssl_certificate      ../certs/{site_name}.local.crt;
	ssl_certificate_key  ../certs/{site_name}.local.key;

	include server-block-ssl.conf;

	location / {

		include location-block.conf;

If that doesn’t work, flick the preferences to use “Local Host”, then back to “Site Domains” and change the site domain to make sure it ends with “.local

This is what worked for me.

1 Like

I’m having this same issue. I go to my C:/Users/mywindowsusername\ and I don’t have a file called AppDataRoaming. I can’t figure this out at all, but it’s SO very frustrating.

Hey Jeff, you may want to check that system folders aren’t hidden. Try just typing the full path into an explorer box, or just go to C:\users\ and try to type your username then a “” then type “appdata” and then a “”. The rest should now appear.

Hi, folks. I have this problem - well, a variation of it. I have never (yet) had any problems accessing a site from the machine where Local is installed.

When I try from another machine on my LAN, I have never (yet) had any success accessing the site. I always get the 404 page. It seems to get to the right place, but something blocks access at the last moment. Add me to the list of frustrated users.

Local (5.6.3) on MacOS (10.15.5) with firewall OFF; simple LAN 10.0.101.* behind an AirPort Extreme router.

Progress!! On another LAN machine running Linux, I modified /etc/hosts similarly to Local’s changes on my Mac. mytestsite.local www.mytestsite.local

On the Mac, the IP address is, of course. This works, but only on the Linux box. So …

  1. How do I set up my iPad which, so far as I know, doesn’t have the equivalent of /etc/hosts?

  2. Better yet, how do I set up the Local machine to do the right thing for everyone on my LAN?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.