502 after updating to 7.0.2

Issue Summary

All sites stuck on ‘starting’ or 502 Request Error when start. Wordpress Version information stuck on loading in the UI.

Troubleshooting Questions

Does this happen for all sites in Local, or just one in particular?

  • All sites.

Are you able to create a new, plain WordPress site in Local and access it in a Browser?

  • Yes.

Describe the steps that others can take to replicate this issue:

  • tried cloning a site, but it gets stuck on setting up and never completes the process.
  • Tried switching web servers. It didn’t fix the issue.
  • Tried switching PHP versions.
  • Tried switching router mode.
  • Tried rolling back to 7.0.1. Error persists.
  • Tried deleting caches in AppData.
  • Tried reinstalling.
  • Tried changing domain ending.

Which version of Local is being used?

  • At first v7.0.1, now v7.0.2+6395 (I upgraded to see if it would fix the issue of only php7 having acceptable performance)

What Operating System (OS) and OS version is being used?

  • Windows 10

local-lightning.log (7.0 KB)


when changing domain ending, after clicking “Fix it” (hosts is writable):

1 Like

Hi @prototowb

Has anything changed with your permissions or security settings? Is there anything that could be blocking Local that maybe “reset” after the update/reinstall?

Are you running any other developer applications simultaneously?

nope@all. And since newly created sites just work, I guess it is something around some internal path rewrites in the app setup.

1 Like

where could I get further assistance? Or how can I recover my sites?

1 Like

Oh, well, never mind. I might have an answer now. Inspecting the site’s folder I saw … that somehow the update must have erased everything leaving only an empty app folder. A week of work - that I only had locally - gone :neutral_face:

1 Like

Hi @prototowb

The update shouldn’t have caused anything to be erased. There aren’t any other files or folders on your machine that could contain the sites?

Have you used any external storage for site files previously?

Did your machine go through any updates?

For future work, we recommend using our free Cloud Backups feature to save all your progress and never lose your work: Cloud Backups

1 Like

No other locations. no external drive. I read your answer in another Thread, that this may happen with a reinstall. Well, free cloud backup sounds lovely, thanks for the tip. I also just should have pushed to GitHub more frequently :tired_face:

I’m sorry you’ve run into this @prototowb! It’s a good reminder for all of us to always be saving and backing up frequently.

I’ve never tried this myself since I don’t have a Windows machine to test on but not sure if this would be an option?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.