502 Request Error on all sites after restarting


I use Local frequently almost always without issues, however last night after restarting my computer all sites present a 502 Request Error.

I tried restarting Local, restarting the computer, creating a new site to see if that worked, etc to no avail.

This looks like the relevant part on local-by-flywheel.log:

Apr 5, 2019, 8:14 PM AST - info: [main/stopSite] Stopping site: running mydumper
Apr 5, 2019, 8:14 PM AST - info: [main/stopSite] Stopping site: stopping container ee4b11827ea10199e6568ec000d5ac550f946dd29368536dbb6054b47d5185fb
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] getRouterContainers()
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] teardown()
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] Removing router container 5e966d694082ab27a91d7db92f711e445a1974130b798fec4b51ef0c9e635fbd
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] updateProxyManager()
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] runContainer()
Apr 5, 2019, 8:16 PM AST - info: [main/docker-router] reconnectNetwork()
Apr 5, 2019, 8:16 PM AST - error: [main/docker-network-manager] Error connecting null to network.
{ message:
'(HTTP code 400) unexpected - invalid name or ID supplied: “” ',
‘Error: (HTTP code 400) unexpected - invalid name or ID supplied: “” \n at /Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/docker-modem/lib/modem.js:239:17\n at getCause (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/docker-modem/lib/modem.js:269:7)\n at Modem.buildPayload (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/docker-modem/lib/modem.js:238:5)\n at IncomingMessage. (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/docker-modem/lib/modem.js:214:14)\n at IncomingMessage.emit (events.js:187:15)\n at IncomingMessage.EventEmitter.emit (domain.js:442:20)\n at endReadableNT (_stream_readable.js:1090:12)\n at process._tickCallback (internal/process/next_tick.js:63:19)’,
reason: undefined,
statusCode: 400,
json: { message: ‘invalid name or ID supplied: “”’ } }

Any ideas about what might be causing this?

I even reinstalled the latest version and nothing.

Any ideas?

Im going crazy trying to find a solution. All the sites I work on are on Flywheel.

Hello @ivand
I’m sorry about this issue. Have you tried restarting the Local by Flywheel VM? How can I forcefully restart the Local by Flywheel VM? Let us know if that helps.

I have been fighting this issue for days, looking for a solution. I tried re-importing from flywheel, reinstalling and importing from local zip, I tried the pre-release build… essentially everything on this forum and all to no avail.

Finally succeeded today, and I hope this helps you too…

  1. I launched VirtualBox and removed Local-by-flywheel.
  2. I relaunched the Local App which went through an initial setup like it was brand new (which is scary because now you wonder if you’ll have to redo everything).
  3. After setup, my long list of sites appeared in red with warnings on each of them. I clicked on a site and saw the “Site Container” warning
  4. Crossed my fingers and clicked “Restore Site” – and it actually did it.
  5. Then I clicked “view site”… and wonder-of-wonders there it was!

I don’t understand what VirtualBox does? I’ve never heard of or used before. I’m on a Mac and wondering what steps to do to use this.

I deleted the app Local-by-flywheel and renamed the Local folder where all the files are stored. Then restarted my machine and reinstalled the app from a fresh download of the app.

Flywheel recreated the Local folder and still showed my 3 sites listed. When I clicked on the site I wanted and started it - then clicked on view site button - still getting the 502 error.

Can you be more specific about VirtualBox?

@rhust you’ve saved my day (if not the previous 3). Thank you!