A JavaScript error occurred in the main process

Uncaught Exception:
RangeError: Invalid typed array length
    at Buffer.Uint8Array (native)
    at FastBuffer (buffer.js:8:1)
    at createUnsafeBuffer (buffer.js:33:12)
    at allocate (buffer.js:176:12)
    at Function.Buffer.allocUnsafe (buffer.js:136:10)
    at tryCreateBuffer (fs.js:474:21)
    at Object.fs.readFileSync (fs.js:519:14)
    at Object.fs.readFileSync (ELECTRON_ASAR.js:506:29)
    at copyFileSync (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/fs-jetpack/lib/copy.js:59:17)
    at copyItemSync (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/node_modules/fs-jetpack/lib/copy.js:85:5)

OS X El Capitan 10.11.6

I already have Pressmatic installed and it works well, but I couldn’t launch Local because of this error. I tried restarting Mac but got the same error.

Interesting, I’ll check into this.

In the meantime you can do this:

  1. Make sure Pressmatic and Local are both closed and not running
  2. Go to ~/Library/Appliation Support (you can get there by pressing Command+Shift+G and pasting that path)
  3. Copy the router, addons, and site-templates directories into Local by Flywheel from Pressmatic
  4. Rename site-templates to blueprints inside Local by Flywheel
  5. Copy all JSON files from Pressmatic to Local by Flywheel
  6. Create a new JSON file named machine.json in Local by Flywheel containing the following:
{
  "name": "pressmatic",
  "image": "pressmatic"
}

After all that is done you can start up Local.

Thanks.

I followed your instruction, but I got the same error.

Also, I tried to delete the Local app and ~/Library/Appliation Support/Local by Flywheel, then re-downloaded and re-installed Local, but this also didn’t work.

The easiest option I found was to;

  1. Uninstall Local by Flywheel
  2. Install MAMP
  3. Perfectamondo :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.