After upgraded to v2.0.2 on my mac it's not starting


I can’t get it started, just see the loading animation there. Here are the logs. Please advice how to make it work. I have few important sites already there which i don’t want to lose.

Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] Running /Applications/Local by stop local-by-flywheel
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] Stopping “local-by-flywheel”…
Jun 5, 2017, 12:14 PM GMT+5 - warn: [main/docker-machine] Machine “local-by-flywheel” is already stopped.
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] Checking Boot2Docker.iso hash
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] child process exited with code 1
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] Running /Applications/Local by start local-by-flywheel
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] Starting “local-by-flywheel”…
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] (local-by-flywheel) Check network to re-create if needed…
Jun 5, 2017, 12:14 PM GMT+5 - info: [main/docker-machine] (local-by-flywheel) Waiting for an IP…
Jun 5, 2017, 12:15 PM GMT+5 - info: [main/docker-machine] Machine “local-by-flywheel” was started.
Jun 5, 2017, 12:15 PM GMT+5 - info: [main/docker-machine] Waiting for SSH to be available…
Jun 5, 2017, 12:15 PM GMT+5 - info: [main/docker-machine] Detecting the provisioner…
Jun 5, 2017, 12:15 PM GMT+5 - info: [main/docker-machine] Started machines may have new IP addresses. You may need to re-run the docker-machine env command.


I am having this issue too.
Docker is booted and ready in VirtualBox but Local by Flywheel doesn’t get past the ‘Starting Local Machine…’ screen.

I am hoping to get this resolved asap, as i am stuck here as i have some under development project there which i can’t access now :frowning:

This is really alarming and annoying.

I can confirm that using 2.0.1 works.

Here’s the download link:

Thanks @jackmcconnell, does one just drop the 2.0.1 version in the /application/ folder — writing over the 2.0.2 version? Or are there any other tricks to jump through?

@richtabor I just dragged and dropped to write over 2.0.2 in Applications. Started it up and it worked fine for me.

1 Like

Thanks! I’m currently sitting on a defunct environment, where it’s insisting that the Pressmatic data does not exist (post).

Maybe downgrading will help… ಠ_ಠ

2.0.2 not starting for me either. Downgraded to 2.0.1 and back to a working local dev setup, BUT, no sites.
I do have Time Machine backups, so can anyone advise what files I need to restore and where to get my system back?

Same problems here. I’ve lost the best part of a whole working day trying to find ways around the problems this has caused. Currently without a working local dev setup. Reverting to 2.0.1 hasn’t brought my sites back.

Hopefully an update is on its way to fix the issues.

Same here. I’ve been able to at least have Local stay open, but it’s suggesting all my containers are missing. This may be the last straw for Local.

Local 2.0.2 does not work with many people.
You will waste hours of your day(s) trying to get it to work.
There is a serious bug in it that no one has consistently solved.
The best you can do is to simply reinstall Local 2.0.1 by overwriting Local 2.0.2 with it.

What about all my ‘lost’ sites? I still have them in the directory, but meanwhile, I’ve had to go back to MAMP Pro and clone a site from the staging server.

It looks like the reference to the sites you are working with are stored in Local’s Application Support folder.

This is located at:

~/Library/Application Support/Local by Flywheel/router/
~/Library/Application Support/Local by Flywheel/routes/

If the reference to your sites are still present in these directories, then downgrading to Local 2.0.1 will reference your “lost” sites.

Thanks very much marianco. I copied over my com.getflywheel.local.hrlper.plist to the preferences directory, plus several json files and the savedState directory.

Back and running with 2.0.1 again.

Hi all,

So sorry for the trouble!

Please try 2.0.3. See Local by Flywheel 2.0.3 (macOS Only)

Thanks Clay. However, this was such a time-consuming issue that it should not have been put out like this. I for one will be letting other, braver souls act as guinea pigs on this version.

I desperately need to get working again, so I’ve given 2.0.3 a go. The app loads fine and I can see the list of my sites. I click to start the site I need to work on which seems to start OK, but then I’m not able to see it in my browser at the local dev URL: ERR_CONNECTION_REFUSED

Nothing much in the log makes sense to me - if I post some of it would anyone be able to see what’s happening maybe? Any help would be greatly appreciated!

1 Like

Hi Shaun,

Please try going to Preferences » Advanced then disabling “Faster Docker Volumes” if it isn’t already.

Yes! Thanks, Clay. That seems to have solved it for me. Hopefully others will get the same result with 2.0.3. I’ll post back here if I spot anything else not as it should be.

I really appreciate the response with the new version release and the preferences change suggestion. Many thanks.

1 Like

Update and note to self:

I successfully installed the 2.0.3 update (over 2.0.1) on my MacBook last night. No issues and no lost sites.

With future updates, I’m going to install these and test in a non-working environment!

Happy to continue promoting Local. Went back to MAMP Pro yesterday and forgot how much more I enjoy working with Local. Only thing still on my very much wanted list is the ability to set database prefix on new installations.