Local Community

*all* files deleted, all directories are empty

Issue Summary

All the files in my Local Sites folder are missing, local is saying I have no sites set up.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Haven’t tried

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
I just tried to run a site, got an plain html page listing the directories, all directories are empty

System Details

  • Which version of Local is being used?
    6.3.0+5756

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      Windows 11 Profesional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Can you share your Local log file? Or a screenshot of the directory you’re looking in? * * Retrieving Local’s Log

I’m not sure I understand what happened - were there any changes to your version of Local or OS? If you create a new site, does it get saved in the Local Sites folder appropriately?

The log file is empty, attached anyway, it’s as though I’ve only just installed Local. I’m not sure what good a screenshot will do but I have attached one anyway, showing the structure of one of the sites and the public folder, which should be full of the WP root files.

I had 6 sites set up in Local, all in constant development, and 5 of them are missing all of their files, their folder structures remain intact. I’ve not used my computer much since last Wednesday 2nd as I’ve been ill. As far as I’m aware no OS or Local updates have run.

As I said, yesterday when I tried to access one of the sites and it didn’t work I checked the Local Sites folder, and as I said, the directory structure was intact, but all the files were missing. Running Local gives me the “Looks like you haven’t set up any sites” intro message.

I’m really confused as to how this could have happened, if I’d somehow accidentally deleted them the folders would have gone too. I can’t think what kind of process could have run that would have done this.

Luckily the sites are either available in Git repo’s, or online, or in my cloud backup, but this is a major pain, and worry.

Cheers,

Zac

local-lightning.log (684 Bytes)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.