Apache Buggy - Wouldn't open Gutenberg

I’ve noticed some rather buggy behavior when utilizing Apache.

Today, I set up a brand new environment to start testing Gutenberg. PHP7.1, Apache, non-multisite.
After I installed the Gutenberg plugin, I clicked New Post, and it gave me a blank screen where the editor should be.
Tried it again, same.

I disabled Gutenberg. Regular post editor came up fine.

I tried PHP7. Same thing.
I switched to Nginx, and it started working.
I switched back to Apache, and it works again.

I’ve had similar issues with Apache on Local by Flywheel in the past. The worst was getting a Multisite set up.

What’s going on with Apache on LBFW?

Hi @WilliamBay,

Sorry for the trouble!

Do you see any errors in the PHP or Apache error logs in the site’s logs folder?

Hi Clay,
Yeah, I’ve created Pastebin pages for you to have access to the error logs. Not sure what all will help, so I’m adding all the logs I can find.
If it helps at all, I’m on Mac High Sierra. Brand new Macbook Pro, and I experienced this on both Chrome and Safari.

I know this just a data dump on you, but hopefully you can find something useful in it. I’m happy to answer any other questions you have as well.

Apache Error Log:

Apache Access Log

MySQL Error Log

NginX Access Log

Nginx Error Log

PHP 7.0.3 php-fpm Log

PHP 7.1.4 Error Log

PHP 7.1.4 php-fpm Log

Hey @WilliamBay,

Thanks for the log files!

The Apache log file is interesting, it shows that it’s getting a SIGTERM and then restarting. It looks like it might be related to the PHP errors in the PHP 7.1.4 error log. Specifically, the following error:

PHP Parse error:  syntax error, unexpected '<', expecting end of file in phar:///usr/local/bin/wp/vendor/rmccue/requests/library/Requests.php on line 54

Is WordPress up-to-date on that site? If not, I’d try updating it.

Otherwise, you may want to try reinstalling the core WordPress files by going to Dashboard » Updates and then clicking Re-install now under You have the latest version of WordPress. Future security updates will be applied automatically.

Hi Clay,
I think I ended up doing that (manually) for a different reason. But WordPress was up to current version at the time.
This issue only affected me that once. I was merely reporting a bug.

If I install Gutenberg again, and the issue repeats itself, I’ll let you know.
Obviously things are still a bit early with Gutenberg. So it could be a number of things.

Thanks. Glad the logs gave you some insight.


1 Like