Local Community

Applying Nginx configuration in LiveLink

Issue Summary

I’m currently trying out LiveLink with a custom Nginx configuration which prevents all users except the
local domain to access the wp-uploads page. However, whenever I try out my site with the LiveLink feature none of the Nginx config is applied at any time, due to the fact that I can still access the wp-uploads folder without any restriction.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    As far as I can tell this only happens to the LiveLink site. The “local” version of my site doesn’t have this problem and throws the 403 error whenever I want to access the uploads directory by using an url.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Replication

I. Create your Local instance by using the following parameters nginx,PHP 7.3.5 and MySQL8.0.16 + Wordpress version 5.8.3
II. Modify the nginx configuration in such a way that you cant access anything inside the uploads folder
III. Create a LiveLink connection afterwards
IV. Try to open the image in LiveLink

System Details

  • Which version of Local is being used?
    6.1.8

  • What Operating System (OS) and OS version is being used?
    Ubuntu Linux 20.04

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.