Auto update now all sites say container missing


Local by Flywheel updated automatically this morning and now all of my local sites are inaccessible, they say “Error!
Container is missing. You will need to restore this site from a backup or previous export.”

From searching here I think I need to follow the steps outlined here:

Is that correct?

Any ideas why this update failed? I have about 15 sites so this is going to be quite a time consuming process today :persevere:

So I went through the steps described with one site and got up to this point:

  1. Rename all of the folders in your Local Sites folder to something like SITE-backup
  2. If the site still exists in Local with a “Container Missing” error, delete it.
  3. Create new sites for each using the existing domains and paths. So, if it was site before, you’ll use site again
  4. Browse back to the Local Sites folder and delete the newly created site folder and rename SITE-backup back to site. This is done because you can’t create sites over site folders that already exist.

For step 4, I had to Stop the site in Local before I coudl delete all the files as Windows gave me an error message saying error.log was in use so it couldn’t remove the directory. So I stopped the site, removed it, renamed the -backup to the original site name, then tried to Start the site but the site just spins forever and never loads.

I’ve tried restarting the local machine but this doesn’t help.

Is there a way to disable auto updates? I don’t have the time to go through 15 sites today, so I’m thinking of doing an entire System Restore to yesterday when everything worked fine.


I’m very sorry for the trouble!

Are you currently on Local 2.2.3? If so, there should be a “Restore” button at the top of each site’s info panel in Local.

Also, can you provide the local-by-flywheel.log file?

Hi @clay,

I’m on 2.2.3. Most sites do have that restore button, and it seems to have worked fine, however one of them says:

Site container is missing. Automatic restore is not available due to missing SQL export.”

Which is strange, because I’m not sure why the sql folder has disappeared!

If I put another site’s SQL in there, restore the site, then just flush the DB and restore a live site dump and do a search-replace that might work.

I’ve attached the two log files here:

local-by-flywheel.log (221.1 KB)
local-by-flywheel1.log (1.0 MB)


i have the same problem.

Did you find the solution?

Thanks :))

The restore sites link with the latest version worked for me, took a while though.

I hope it doesn’t happen with the next update!

@clay there are some sites that I haven’t worked on in a while which are refusing to start. When I click Start it just says “Starting…” forever. This is happening to 16 out of 19 sites!!! Only 3 work. Is there a forced “Restore site” option I can enable somehow?

I’ve tried updating to 2.2.4 and rebooting multiple times but I still have the same issue.

I’ve been through the steps here - How can I restore a site from a Local site folder? even though there was no container missing message. It didn’t work, I got a bad gateway error. In the end I’ve had to create a new site, resync the database and then replace all the files with the live site files. This is quite time consuming and its the second time this bug has happened. If it happens again I’ll have to switch back to XAMPP or Desktop Server.