Bedrock installation : Issue with database

What issue or error are you experiencing?

Hello,

I have quite good experience with Bedrock and Local.

Last year I have already tried to use a Bedrock website inside Local with success, but this time it doesn’t seem to work.

I followed this guide: Bedrock with Local | Bedrock Docs | Roots

I tried many stuff but I still have the DB issue when trying to access WordPress, despite I’m able to connect to the DB with SequelPro for example.

my .env file is pretty common:

DB_NAME='local'
DB_USER='root'
DB_PASSWORD='root'
DB_HOST='localhost'

WP_HOME='http://localhost:10039'
WP_SITEURL="${WP_HOME}/wp"

I updated the nginx config accordingly as well. Is there a recent change to the software that impacted this kind of custom setup maybe?

I tried with both different router mode, localhost and custom domain name, it doesn’t change the issue.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    Version 8.2.0+6554

  • Operating System (OS) and OS version:
    MacOs Ventura13.4 (22F66)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
No logs


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @ftiar91

I’m not experienced with Bedrock myself but I think there might be some issues with that article. The information provided here might be helpful:

We also have a feature request for Bedrock here if you want to vote or comment: