Blueprints from multisite installations do not work

If you create a blueprint from a multisite installation, then any sites built from that blueprint will redirect to the original installation.

For example, make a new multisite (subdirectory) local site called “TestMU” with a domain name of “”. This should work fine.

Now ask Local to make a blueprint from that local site.

Finally, create a new local site called “TestMU 2” and use the blueprint you just created, it should have the domain name “”. No errors will be reported.

Now try try to visit the second site, You will be redirected to instead.

Something seems to be wrong about how Local deals with multisite.

I believe this is fixed in an upcoming version but I’ll double-check. In the meantime you can change the URL using WP-CLI. See Problem of redirecting the local site to online site

Thanks for the heads up!

Huh. OK. That kind of makes blueprints much less useful. I would hope that in the future they are smart enough to search-replace domain references automatically as part of a setup from blueprint. Or at least warn the user that this critical task is left undone by blueprints. But thanks for the pointer!

It does automatically search-replace.

However, there are a few things missed searching and replacing with multisite in the current version of Local. The fix has already been written and implemented in an upcoming version of Local :slight_smile:

Super! Looking forward to the upcoming version then.

Thanks for all the effort put into Local. It feels like magic, which is, I guess, why it is so jarring when something does not work. The team is doing a magnificent job for the community and I am very grateful that you share this so openly with the WordPress community.

I agree with efc, the team is doing a great job and I am very happy with Local.

I run into the same situation and I thought the version I’m using (2.2.4) had the fix already but it does not.

So for now, I did the WP-CLI search-replace command and that worked.


I was able to reproduce the issue in Local 2.3.2. We’ll look into fixing this ASAP.

Thanks for the heads up!

Hi Clay,

You are welcome!

I’ll keep an eye when this is working, it is handy to have a multi-site blueprint.