Blueprint Sites Only Work if Switching to nginx (win 10)

I figured I might start a new thread about this since my replies on another thread were starting to drift off topic.

Recently using 2.1.1 I realize that all sites I create from my old blueprints (that are WP 4.9 and Apache) give a 500 Internal Error UNLESS… I change the web server to “nginx”. Upgraded to 2.1.2 and issue persists.

However, my blueprints are Apache and I’d like to continue working in Apache so that when the time comes to upload to my webhost, it will work. Oh another thing, the only sites I’ve been able to create off the blueprints and STILL work in Apache are those that I named the same as the original site that the blueprint was made from.

So my current workaround right now is to work in nginx mode but I’m worried of whether or not my site will work when the time comes to upload it to an apache remote host. Something’s not right here obviously.

NOTE: I am able to reproduce the error on both my desktop AND my laptop. In both cases, the only workaround is to switch my web server to nginx.


I only have 2 options at this point: change my newly created sites to nginx and hope for the best when i upload to apache remote server, OR, stop using blueprints to create a new site because Apache works for the new site as long as it is not based on a blueprint.

Other thing I notice is that I still get VirtualBox notice on shutdown of computer - even if all sites stopped and properly exited Local Flywheel. Also, the Database–>Adminer function leads to 500 error for these sites based on the blueprints.

I’m having the exact same issue. When creating a site from a blueprint I get a 500 internal server error unless i change to nginx. Any solutions? I would like to use Apache too.

I was just about to post a question with using blueprints. I had also created a Apache blue print and when I loaded the site I got the following message Front to the WordPress application. This file doesn't do anything, but loads and it look liked it just loads plain .txt or the content of some sort of .php file.

Because of this thread I moved to Nginx and then the site worked as expected.

I am on macOS 10.13 and flywheel version 2.3.3.

I see this thread is almost year old now any solutions?