Bug: Local 5.2.8 on PHP 7.4.1 doesn't create thumbnails from JPEGs

I’ve tried this on the newest version of Local 5.2.8+2771, and I’ve tested brand new installs on both PHP 7.3.5 and PHP 7.4.1 (current versions at the time of this post). It would seem that 7.4.1 does not create image thumbnails from jpg/jpeg images when uploaded to the media library. However, a barebones install (clicking the fat green + and that’s it) with 7.3.5 does everything as expected.

When running the Regenerate Thumbnails plug-in it gives this error:

The current image editor cannot process this file type.

I’ve tried it, with multiple file types of the same image and multiple barebones install, and it seems that this is isolated to only jpg/jpeg images, leading me to think there’s an extension issue with the current compiled version of PHP 7.4.1.

1 Like

I’m experiencing the same issue. Just JPGS. When I try to edit any JPG, I get the error

"Image rotation is not supported by your web host." 

When I try with Regenerate Thumbnails plugin, it gives:

The current image editor cannot process this file type.

The only way I can fix this is downgrading PHP to 7.3.5.

1 Like

I’m having the exact same issue on version 5.6.6. PNGs do fine. Also I’m on macOS Catalina. I’ve tried on PHP 7.3.5 and 7.4.1.

Edit: just found a another post where they have a temporary fix, if anyone is looking.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.